Bug 1614 - .po files do not open in GNU Emacs
: .po files do not open in GNU Emacs
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/gettext)
: unstable
: all Linux
: P5 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-11-25 16:05 by
Modified: 2003-08-25 15:18 (History)


Attachments
1614-gettext-po-mode-start.el (418 bytes, application/octet-stream)
2002-11-25 17:16, Sergey Vlasov
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-11-25 16:05:37
(The bug is really in the gettext-tools subpackage, but it is not listed in the
BTS)

When trying to load a .po file in GNU Emacs with gettext-tools-0.11.5-alt9
installed, the file does not open with the error message:

insert-file-contents: Autoloading failed to define function
po-find-file-coding-system

The problem is that /etc/emacs/site-start.d/gettext.el specifies:

(autoload \'po-find-file-coding-system \"po-mode\")

However, in the new gettext-tools this function was relocated into
po-compat.el; the autoload declaration needs to be fixed.
---

---
------- Comment #1 From 2002-11-25 16:17:04 -------
Patches are welcome.
------- Comment #2 From 2002-11-25 16:17:04 -------
Patches are welcome.
------- Comment #3 From 2002-11-25 17:18:08 -------
Here is the fixed gettext-po-mode-start.el; no changes in spec are necessary.
Seems to work with all *.po files from Sylpheed (the encoding is switched
appropriately).
------- Comment #4 From 2002-11-25 17:18:08 -------
Here is the fixed gettext-po-mode-start.el; no changes in spec are necessary.
Seems to work with all *.po files from Sylpheed (the encoding is switched
appropriately).
------- Comment #5 From 2002-12-02 16:08:09 -------
Applied in gettext-0.11.5-alt10
------- Comment #6 From 2002-12-02 16:08:09 -------
Applied in gettext-0.11.5-alt10