Bug 17058 - File::Temp regression
: File::Temp regression
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/perl-base)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-09-08 19:21 by
Modified: 2010-11-14 16:19 (History)


Attachments
restore cwd at the end of script (1.74 KB, patch)
2010-11-14 12:36, Vladimir Lettiev
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-09-08 19:21:12
In current Sisyphus "srpmcmp --deep" is broken:

[builder@people .in]$ rpmquery perl-base srpmcmp 
perl-base-5.8.8-alt20
srpmcmp-0.2-alt3
[builder@people .in]$ srpmcmp --deep basesystem-sisyphus-alt17.src.rpm{,}
End of diff

cannot fetch initial working directory: No such file or directory at
/usr/lib/perl5/File/Temp.pm line 901
------- Comment #1 From 2008-09-08 20:18:21 -------
With "basesystem" package, plain srpmcmp doesn't work, too:

[builder@people .in]$ rpmquery perl-base srpmcmp
perl-base-5.8.8-alt21
srpmcmp-0.2-alt3
[builder@people .in]$ srpmcmp basesystem-sisyphus-alt17.src.rpm{,}
End of diff

cannot fetch initial working directory: No such file or directory at
/usr/lib/perl5/File/Temp.pm line 901
------- Comment #2 From 2008-09-08 21:17:22 -------
with perl-base-5.8.8-alt16 works yet,
with perl-base-5.8.8-alt17 no longer works.

BTW,
$ srpmcmp /foo >/dev/null 
[builder@people .in]$
$ srpmcmp /foo            
usage:
/usr/bin/srpmcmp [--deep] [--autocrap] [--rcs] package1.src.rpm
package2.src.rpm
See srpmcmp(1) for details.
------- Comment #3 From 2008-09-25 18:59:32 -------
(In reply to comment #2)
> with perl-base-5.8.8-alt16 works yet,
> with perl-base-5.8.8-alt17 no longer works.

perl-base-5.8.8-alt22 still doesn't work.
------- Comment #4 From 2008-10-07 16:38:02 -------
(In reply to comment #3)
> (In reply to comment #2)
> > with perl-base-5.8.8-alt16 works yet,
> > with perl-base-5.8.8-alt17 no longer works.
> 
> perl-base-5.8.8-alt22 still doesn't work.

perl-base-5.8.8-alt23 still doesn't work. :(
------- Comment #5 From 2008-11-01 13:12:31 -------
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > with perl-base-5.8.8-alt16 works yet,
> > > with perl-base-5.8.8-alt17 no longer works.
> > 
> > perl-base-5.8.8-alt22 still doesn't work.
> 
> perl-base-5.8.8-alt23 still doesn't work. :(

perl-base-5.8.8-alt24 still doesn't work. :((
------- Comment #6 From 2009-03-29 12:31:33 -------
(В ответ на комментарий №5)
perl-base-5.8.9-alt1.1: srpmcmp работает, но временные каталоги не удаляются.
(см. bug #19387)
------- Comment #7 From 2009-03-29 12:31:55 -------
*** Bug 19387 has been marked as a duplicate of this bug. ***
------- Comment #8 From 2010-11-14 04:13:17 -------
perl-base-5.12.2-alt00, временные каталоги всё так же не удаляются.
------- Comment #9 From 2010-11-14 12:36:32 -------
Created an attachment (id=4657) [details]
restore cwd at the end of script

restore cwd at the end of script
------- Comment #10 From 2010-11-14 12:39:53 -------
Сообщение об ошибке стало более адекватным:
cannot remove path when cwd is /tmp/.private/crux/srpmcmp.Zib8UWiHlD for
/tmp/.private/crux/srpmcmp.Zib8UWiHlD:  at /usr/share/perl5/File/Temp.pm line
902

Т.о. каталог не удаляется, поскольку текущий каталог процесса находится в
удаляемом каталоге.
Думаю надо патчить srpmcmp, чтобы он восстанавливал текущий каталог перед
завершением работы
------- Comment #11 From 2010-11-14 16:19:17 -------
OK, тогда закрываю.