Bug 17634 - it's difficult to install well-known git commands
: it's difficult to install well-known git commands
Status: CLOSED FIXED
: ALT Linux Office Server
(All bugs in ALT Linux Office Server/packages)
: не указана
: all Linux
: P2 normal
Assigned To:
:
:
:
: 15477
:
  Show dependency tree
 
Reported: 2008-10-20 21:45 by
Modified: 2009-04-09 19:29 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-10-20 21:45:24
Office Server 4.0.0

There is no maximal "git" package. So I selected by hand in Synaptic some git-*
packages including git-core-1.5.3.8-alt1 and other.

But then it turned out that "git remote" wasn't present as a result. (By
reading 
https://bugzilla.altlinux.org/show_bug.cgi?id=15477 I found out that I should
install perl-Git for it.) But installing perl-Git is not an obvious thing to
do.

I suggest either to include a maximal "git" package to the distribution, or to
add a requirement on perl-Git to git-core, or at least to mention perl-Git in
the description of git-core.

Current situation is bad, because it leaves the impression that perl-Git is
only for Perl programming, but, as it turns out, it contains commands to be run
from the shell as well.
------- Comment #1 From 2008-10-21 17:23:09 -------
Передаю крайнему
------- Comment #2 From 2009-04-09 19:29:53 -------
Непонятно, причём тут Школьный/Офис сервер, да и давно не актуально, насколько
я понимаю...