Bug 17750 - не хватает pychcker, pychecker2
: не хватает pychcker, pychecker2
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/spe)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-10-31 13:57 by
Modified: 2009-04-11 14:57 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-10-31 13:57:46
при попытке запуска:

rt@localhost python2.5/site-packages/_spe $ spe

SPE v0.8.4.h (c)2003-2008 www.stani.be

If spe fails to start:
 - type "python SPE.py --debug > debug.txt 2>&1" at the command prompt
   (or if you use tcsh: "python SPE.py --debug >& debug.txt")
 - send debug.txt with some info to spe.stani.be[at]gmail.com

Traceback (most recent call last):
  File "/usr/bin/spe", line 3, in <module>
    import _spe.SPE
  File "/usr/lib/python2.5/site-packages/_spe/SPE.py", line 55, in <module>
    import Menu,Parent,Child
  File "/usr/lib/python2.5/site-packages/_spe/Parent.py", line 25, in <module>
    import Child
  File "/usr/lib/python2.5/site-packages/_spe/Child.py", line 24, in <module>
    import _spe.plugins.Pycheck as Pycheck
  File "/usr/lib/python2.5/site-packages/_spe/plugins/Pycheck.py", line 17, in
<module>
    import _spe.plugins.pychecker as pychecker
ImportError: No module named pychecker

Ок, делаем sudo apt-get install pychecker
теперь получаем:

rt@localhost python2.5/site-packages/_spe $ spe

SPE v0.8.4.h (c)2003-2008 www.stani.be

If spe fails to start:
 - type "python SPE.py --debug > debug.txt 2>&1" at the command prompt
   (or if you use tcsh: "python SPE.py --debug >& debug.txt")
 - send debug.txt with some info to spe.stani.be[at]gmail.com

Traceback (most recent call last):
  File "/usr/bin/spe", line 3, in <module>
    import _spe.SPE
  File "/usr/lib/python2.5/site-packages/_spe/SPE.py", line 55, in <module>
    import Menu,Parent,Child
  File "/usr/lib/python2.5/site-packages/_spe/Parent.py", line 25, in <module>
    import Child
  File "/usr/lib/python2.5/site-packages/_spe/Child.py", line 24, in <module>
    import _spe.plugins.Pycheck as Pycheck
  File "/usr/lib/python2.5/site-packages/_spe/plugins/Pycheck.py", line 22, in
<module>
    import _spe.plugins.pychecker2 as pychecker2
ImportError: No module named pychecker2
------- Comment #1 From 2009-04-11 11:39:59 -------
*** Bug 17899 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2009-04-11 11:40:47 -------
*** Bug 19366 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2009-04-11 14:57:08 -------
spe-0.8.4.h-alt2 -> sisyphus:

* Sat Apr 11 2009 Fr. Br. George <george@altlinux> 0.8.4.h-alt2

- PyCheker dependency (closes: #17750)
- Python module separation