Bug 17859 - the *-devel is installed without the main package
: the *-devel is installed without the main package
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/python-module-imaging)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-11-12 01:23 by
Modified: 2009-08-14 21:34 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-11-12 01:23:32
python-module-imaging-devel-1.1.4-alt11.1

As it happened in the situation
https://bugzilla.altlinux.org/show_bug.cgi?id=17858 , the *-devel package is
installed without the main package. This seems to be wrong.

And, actually, that situation should be understood as: the *-devel package is
installed *instead* of the main package.

The reason: 

apt> showpkg  python2.5(PIL)
Package: python2.5(PIL)
Versions: 

Reverse Depends: 
  trac-gallery,python2.5(PIL)
  uniconvertor,python2.5(PIL)
  skencil,python2.5(PIL)
  sK1,python2.5(PIL)
  python-module-opencv,python2.5(PIL)
  gnofract4d,python2.5(PIL)
Dependencies: 
Provides: 
Reverse Provides: 
python-module-imaging-devel 1.1.4-alt11.1
python-module-imaging 1.1.4-alt11.1
apt> 

So, if a package like skencil depends on python2.5(PIL), apt-get selects
python-module-imaging-devel and doesn't install python-module-imaging.
------- Comment #1 From 2008-12-23 19:21:08 -------
ну нынче уже 1.1.6 с полностью переписанным спеком, так что думаю, что оно
просто неактуально...
------- Comment #2 From 2008-12-23 19:21:27 -------
ну нынче уже 1.1.6 с полностью переписанным спеком, так что думаю, что оно
просто неактуально...
------- Comment #3 From 2008-12-23 23:38:10 -------
(In reply to comment #2)
> ну нынче уже 1.1.6 с полностью переписанным спеком, так что думаю, что оно
> просто неактуально...

Нет, во-первых, и в Sisyphus та же проблема:

apt> showpkg python2.5(PIL)
Package: python2.5(PIL)
Versions: 

Reverse Depends: 
  trac-gallery,python2.5(PIL)
  python-module-phatch,python2.5(PIL)
  python-module-dabo,python2.5(PIL)
  intipunku,python2.5(PIL)
  uniconvertor,python2.5(PIL)
  sK1,python2.5(PIL)
  python-module-pycaptcha,python2.5(PIL)
  python-module-opencv,python2.5(PIL)
  gnofract4d,python2.5(PIL)
Dependencies: 
Provides: 
Reverse Provides: 
python-module-imaging 1.1.4-alt11.1
python-module-imaging-devel 1.1.6-alt2
python-module-imaging 1.1.6-alt2
apt> install python-module-imaging-devel
apt> 

Видно: *-devel устанавливается без основного пакета (и установится вместо него
по зависимостям).

Во-вторых, сообщение было про Branch 4.1, а там 1.1.4.
------- Comment #4 From 2008-12-24 19:04:04 -------
Демонстранция проблемы:

apt> install uniconvertor 
Unrequested changes are needed to execute this operation.
The following NEW packages will be installed:
  python-module-imaging-devel uniconvertor
0 upgraded, 2 newly installed, 0 removed and 0 kept.
Will need more 1081kB of archives.
After unpacking will need more 3855kB of disk space.
Do you want to continue? [Y/n] 
apt> commit 
The following NEW packages will be installed:
  python-module-imaging-devel uniconvertor
0 upgraded, 2 newly installed, 0 removed and 1916 not upgraded.
Need to get 1071kB/1081kB of archives.
After unpacking 3855kB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 ftp://ftp.altlinux.org i586/classic uniconvertor 1.1.2-alt1 [1071kB]
Fetched 1071kB in 0s (5075kB/s)
Committing changes...
Preparing...                                 
###################################################################################################
[100%]
1: python-module-imaging-devel               
###################################################################################################
[ 50%])
2: uniconvertor                              
###################################################################################################
[100%])
Running /usr/lib/rpm/posttrans-filetriggers
Done.
Reading Package Lists... Done
Building Dependency Tree... Done
apt> quit 
[ivan@dell ~]$ cd tmp
[ivan@dell tmp]$ uniconv
/usr/share/epiphany/icons/hicolor/scalable/actions/bookmark-view.svg
test-uniconv-out.svg
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/uniconvertor/__init__.py", line 64, in
<module>
    from app.io import load
  File "/usr/lib/python2.5/site-packages/uniconvertor/app/__init__.py", line
62, in <module>
    from conf.configurator import Configurator
  File
"/usr/lib/python2.5/site-packages/uniconvertor/app/conf/configurator.py", line
11, in <module>
    from app.events import connector
  File "/usr/lib/python2.5/site-packages/uniconvertor/app/__init__.py", line
114, in <module>
    _import_PIL()
  File "/usr/lib/python2.5/site-packages/uniconvertor/app/__init__.py", line
103, in _import_PIL
    warn.warn(warn.USER, "Can't import the Python Imaging Library")
NameError: global name 'warn' is not defined
[ivan@dell tmp]$ 
------- Comment #5 From 2008-12-24 19:08:03 -------
Если вручную разбираться с зависимостями, оно на самом деле работает:

[ivan@dell tmp]$ ftp_proxy= http_proxy= sudo apt-shell 
Reading Package Lists... Done
Building Dependency Tree... Done
Welcome to the APT shell. Type "help" for more information.
apt> remove python-module-imaging-devel 
Unrequested changes are needed to execute this operation.
The following packages will be REMOVED:
  python-module-imaging-devel uniconvertor
0 upgraded, 0 newly installed, 2 removed and 0 kept.
Will need more 0B of archives.
After unpacking 3855kB disk space will be freed.
Do you want to continue? [Y/n] 
apt> commit 
The following packages will be REMOVED:
  python-module-imaging-devel uniconvertor
0 upgraded, 0 newly installed, 2 removed and 1916 not upgraded.
Need to get 0B of archives.
After unpacking 3855kB disk space will be freed.
Do you want to continue? [Y/n] 
Committing changes...
Preparing...                                 
###################################################################################################
[100%]
Running /usr/lib/rpm/posttrans-filetriggers
Done.
Reading Package Lists... Done
Building Dependency Tree... Done
apt> install python-module-imaging
apt> install uniconvertor 
apt> commit 
The following NEW packages will be installed:
  python-module-imaging uniconvertor
0 upgraded, 2 newly installed, 0 removed and 1916 not upgraded.
Need to get 346kB/1417kB of archives.
After unpacking 5445kB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 ftp://ftp.altlinux.org i586/classic python-module-imaging 1.1.6-alt2
[346kB]
Fetched 346kB in 0s (2683kB/s)         
Committing changes...
Preparing...                                 
###################################################################################################
[100%]
1: python-module-imaging                     
###################################################################################################
[ 50%])
2: uniconvertor                              
###################################################################################################
[100%])
Running /usr/lib/rpm/posttrans-filetriggers
Done.
Reading Package Lists... Done
Building Dependency Tree... Done
apt> quit 
[ivan@dell tmp]$ uniconv
/usr/share/epiphany/icons/hicolor/scalable/actions/bookmark-view.svg
test-uniconv-out.svg
[ivan@dell tmp]$ 

Так что надо разобраться:
1) как так python-module-imaging-devel предоставляет python2.5(PIL)?
2) как так python-module-imaging-devel может установиться без
python-module-imaging?
------- Comment #6 From 2008-12-24 22:59:03 -------
> Так что надо разобраться:
> 1) как так python-module-imaging-devel предоставляет python2.5(PIL)?
Ну это реальный баг упаковки... собсно пакет вообще неработоспособен нынче...
> 2) как так python-module-imaging-devel может установиться без python-module-imaging?
Ну видимо это ещё один баг...

Вообще у этого пакета была целая куча мечтающих его починить... в результате
один человек таки его обновил, но пользоваться всё равно нельзя...
------- Comment #7 From 2009-06-30 17:33:47 -------
Перевешу на sisyphus. Актуальна ошибка на всех бранчах тоже.
------- Comment #8 From 2009-08-14 21:28:54 -------
(В ответ на комментарий №7)
> Перевешу на sisyphus. Актуальна ошибка на всех бранчах тоже.

судя по всему никому не надо, но таки закинул alt3 в сизиф
------- Comment #9 From 2009-08-14 21:34:51 -------
#10717 DONE sisyphus python-module-imaging.git=1.1.6-alt3