Bug 18396 - doesn't show in KDE tray if run from ~/.xsession.d/
: doesn't show in KDE tray if run from ~/.xsession.d/
Status: CLOSED WONTFIX
: Branch 4.1
(All bugs in Branch 4.1/stardict-gtk)
: unspecified
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-12-29 21:41 by
Modified: 2014-11-05 20:41 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-12-29 21:41:41
stardict-gtk-3.0.0-alt1 in Desktop 4.1.1RC 2008/11/15

Starting a program from ~/.xsession.d/ is the universal way to do it (and even
the only one I know: I couldn't find an analogous KDE facility -- see another
bugreport):

$ l ~/.xsession.d/stardict-gtk 
lrwxrwxrwx 1 imz imz 21 Дек 28 22:43 /home/imz/.xsession.d/stardict-gtk ->
/usr/bin/stardict-gtk
$ 

But there is one inconvenience when this is done for stardict and KDE is being
used: the icon of stardict doesn't appear in the tray on the panel (probably,
because of the order: first stardict is started, and only then the KDE
initialization completes).

If stardict is started manually inside KDE, then its icon does appear in the
tray.

Expected behaviour: also if stardict is run from ~/.xsession.d/, then it should
add its icon to the KDE tray (after the KDE initialization completes).
------- Comment #1 From 2014-11-05 20:41:58 -------
В 4.1/branch исправления не будут вноситься уже технически (заглушена очередь
на сборку), поэтому прошу ошибки, актуальные для sisyphus/p7/t7, перевесить на
текущие ветки или сизиф.