Bug 18651 - missing ghostscript-classic in buildrequires
: missing ghostscript-classic in buildrequires
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/nasm)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-01-26 13:22 by
Modified: 2009-06-22 15:51 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-01-26 13:22:17
Сборка падает так:
perl ./genpsdriver.pl > nasmdoc.ps
false            -n -q --nosecurity -o nasmdoc.pdf nasmdoc.ps || \
        ps2pdf           nasmdoc.ps nasmdoc.pdf || \
        false            nasmdoc.ps -o nasmdoc.pdf
/usr/bin/ps2pdfwr: line 45: exec: gs: not found
make[1]: Leaving directory `/usr/src/RPM/BUILD/nasm-2.05.01/doc'
make[1]: *** [nasmdoc.pdf] Error 1
make: Leaving directory `/usr/src/RPM/BUILD/nasm-2.05.01'


RPM build errors:
make: *** [doc] Error 2
error: Bad exit status from /usr/src/tmp/rpm-tmp.21575 (%build)
    Bad exit status from /usr/src/tmp/rpm-tmp.21575 (%build)
Command exited with non-zero status 1
21.46user 4.30system 0:12.15elapsed 212%CPU (0avgtext+0avgdata 0maxresident)k
0inputs+0outputs (0major+887920minor)pagefaults 0swaps
hsh-rebuild: rebuild of `nasm-2.05.01-alt1.src.rpm' failed.


Поскльку buildrequire содержит ghostscript-utils, но не ghostscript-classic
------- Comment #1 From 2009-06-22 15:51:49 -------
(В ответ на комментарий №0)
> 
> Поскльку buildrequire содержит ghostscript-utils, но не ghostscript-classic

Не воспроизводится, поскольку:

packagereq: optimized out: fontconfig ghostscript-classic ghostscript-common
glibc-pthread
packagereq: BuildRequires: ghostscript-utils groff-base