Bug 18724 - Desn't work with XULRunner
: Desn't work with XULRunner
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/eclipse-swt)
: unstable
: all Linux
: P2 normal
Assigned To:
:
: http://www.eclipse.org/swt/faq.php#br...
:
:
:
  Show dependency tree
 
Reported: 2009-02-02 16:05 by
Modified: 2010-12-17 22:44 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-02-02 16:05:03
A: You need one of the following:
...
# XULRunner 1.9.x can be used with Eclipse 3.4 and newer
...
If you are using an eclipse prior to version 3.2.1, or if you want the Browser
to use a GRE (such as Mozilla) that you have installed yourself, then you must
set the MOZILLA_FIVE_HOME environment variable to the folder containing your
GRE (e.g. setenv MOZILLA_FIVE_HOME /usr/lib/mozilla), and prepend this
directory to your LD_LIBRARY_PATH environment variable.

На примере vuze видно, что оно пытается использовать GRE и у него это не очень
получается.  Кто-то как-то не так собран?

http://git.altlinux.org/people/raorn/packages/?p=vuze.git;a=blob;f=vuze/org/gudy/azureus2/platform/unix/ScriptBeforeStartup.java;h=5f679379c7bfc167233c82956fbfc543a8ab8700;hb=d5aa17c038c1d0f691162509c20eee8b31ab7c3e#l201
------- Comment #1 From 2010-12-17 22:44:46 -------
в Сизиф ушла новая версия eclipse, надеюсь, проблема рассосалась.