Bug 18916 - не работает печать на самба-принтер из firefox 3.0.4
: не работает печать на самба-принтер из firefox 3.0.4
Status: CLOSED FIXED
: ALT Linux Desktop
(All bugs in ALT Linux Desktop/packages)
: 4.1.1
: x86 Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-02-20 12:08 by
Modified: 2011-05-20 17:34 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-02-20 12:08:40
в сети есть виндовс машина с расшаренным принтером HP 1018.
на машине ALTLinux Desktop 4.1.1 принтер подключен стандартным средством
настройки принтеров КДЕ. Все приложение (например ооо, kwrite) отправляют
задания на принтер корректно и они нормально выполняются, кроме firefox/

в /var/spool/cups задание появляется...

в логах при печати из ооо (тоесть когда печать работает):
Feb 19 15:39:56 kredit foo2zjs-wrapper: foo2zjs-wrapper -P -z1 -L0 -r1200x600
-p1 -s7 -m1 -n1
Feb 19 15:39:59 kredit foo2zjs-wrapper: gs -sPAPERSIZE=letter -g10200x6600
-r1200x600 -sDEVICE=pbmraw -dCOLORSCREEN -dMaxBitmap=500000000
Feb 19 15:39:59 kredit foo2zjs-wrapper: foo2zjs -r1200x600 -g10200x6600 -p1 -m1
-n1 -d1 -s7 -z1  -u 192x96 -l 192x96 -L 0     -P

в логах при печати из firefox (когда не работает):
Feb 19 15:44:39 kredit foo2zjs-wrapper: foo2zjs-wrapper -P -z1 -L0 -r1200x600
-pCustom.595x842 -s7 -m1 -n1
Feb 19 15:44:39 kredit foo2zjs-wrapper: gs -sPAPERSIZE=letter -gx -r1200x600
-sDEVICE=pbmraw -dCOLORSCREEN -dMaxBitmap=500000000
Feb 19 15:44:39 kredit foo2zjs-wrapper: foo2zjs -r1200x600 -gx -p256 -m261 -n1
-d1 -s7 -z1  -u 2x100 -l 2x100 -L 0     -P

логи cups
acces_log:
localhost - - [19/Feb/2009:16:20:33 +0300] "POST / HTTP/1.1" 200 418
CUPS-Get-Printers successful-ok
localhost - - [19/Feb/2009:16:20:33 +0300] "POST / HTTP/1.1" 200 418
CUPS-Get-Classes successful-ok
localhost - - [19/Feb/2009:16:20:33 +0300] "POST / HTTP/1.1" 200 75
CUPS-Get-Default client-error-not-found
localhost - - [19/Feb/2009:16:20:33 +0300] "POST / HTTP/1.1" 200 418
CUPS-Get-Printers successful-ok
localhost - - [19/Feb/2009:16:20:33 +0300] "POST / HTTP/1.1" 200 418
CUPS-Get-Classes successful-ok
localhost - - [19/Feb/2009:16:20:33 +0300] "POST / HTTP/1.1" 200 75
CUPS-Get-Default client-error-not-found
localhost - - [19/Feb/2009:16:20:33 +0300] "POST / HTTP/1.1" 200 288
CUPS-Get-Printers successful-ok
localhost - - [19/Feb/2009:16:20:33 +0300] "GET /ppd/HP1018.ppd HTTP/1.1" 200
19607 - -
localhost - - [19/Feb/2009:16:20:36 +0300] "POST /printers/HP1018 HTTP/1.1" 200
56168 Print-Job successful-ok

error_log:
I [19/Feb/2009:16:20:36 +0300] [Job Непонимающий] Request file type is
application/postscript.
I [19/Feb/2009:16:20:36 +0300] [Job 36] Adding start banner page "none".
I [19/Feb/2009:16:20:36 +0300] [Job 36] Adding end banner page "none".
I [19/Feb/2009:16:20:36 +0300] [Job 36] File of type application/postscript
queued by "kredit".
I [19/Feb/2009:16:20:36 +0300] [Job 36] Queued on "HP1018" by "kredit".
I [19/Feb/2009:16:20:37 +0300] [Job 36] Started filter
/usr/lib/cups/filter/pstops (PID 27567)
I [19/Feb/2009:16:20:37 +0300] [Job 36] Started filter
/usr/lib/cups/filter/foomatic-rip (PID 27568)
I [19/Feb/2009:16:20:37 +0300] [Job 36] Started backend
/usr/lib/cups/backend/smb (PID 27569)
I [19/Feb/2009:16:20:38 +0300] [Job 36] Completed successfully.
------- Comment #1 From 2011-02-16 06:26:26 -------
Эта бага еще актуальна?
------- Comment #2 From 2011-05-20 15:39:11 -------
(В ответ на комментарий №1)
> Эта бага еще актуальна?

Да актуальна, пробовал менять параметры не помогает (hp-1020)
------- Comment #3 From 2011-05-20 15:42:22 -------
(В ответ на комментарий №2)
> (В ответ на комментарий №1)
> > Эта бага еще актуальна?
> 
>Щас сижу на p5 (simply)
------- Comment #4 From 2011-05-20 16:21:00 -------
Если "отодвинуть" ~/.mozilla и попробовать на новом (чистом) профиле, проблема
остается?
На новом тестовом юзере проблема остается?
------- Comment #5 From 2011-05-20 16:43:10 -------
(В ответ на комментарий №4)
> Если "отодвинуть" ~/.mozilla и попробовать на новом (чистом) профиле, проблема
> остается?
> На новом тестовом юзере проблема остается?

Спасибо помогло (удалил .mozilla)
------- Comment #6 From 2011-05-20 17:34:28 -------
Жаль что удалили, можно было бы покопаться в проблеме