Bug 1948 - menu-select crashes zsh
: menu-select crashes zsh
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/zsh)
: unstable
: all Linux
: P5 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-01-15 14:17 by
Modified: 2003-09-22 15:50 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-01-15 14:17:05
[<a href="mailto:vsu@center4" target="_new">vsu@center4</a> vsu]$ rpm -q zsh
zsh-4.0.6-alt1
[<a href="mailto:vsu@center4" target="_new">vsu@center4</a> vsu]$ zsh
<a href="mailto:vsu@center4" target="_new">vsu@center4</a> ~ $ zmodload zsh/complist
<a href="mailto:vsu@center4" target="_new">vsu@center4</a> ~ $ 
  (press M-x menu-select RET)
Segmentation fault                

zsh-4.0.4-alt4 (from Master 2.0) segfaults too (or sometimes inserts garbage into the command line).
---

---

------- Comment #1 From 2003-08-26 14:31:24 -------
new packager
------- Comment #2 From 2003-08-26 14:46:46 -------
real maintainer is at@ :)
------- Comment #3 From 2003-09-22 15:00:11 -------
unable to reproduce with zsh-1:4.1.1-alt2
------- Comment #4 From 2003-09-22 15:50:08 -------
And according to the docs zsh/complist was not supposed to be loaded this
way...