Bug 1955 - mod_ruby package has incorrect scriptlet
: mod_ruby package has incorrect scriptlet
Status: CLOSED DUPLICATE of bug 1809
: Sisyphus
(All bugs in Sisyphus/mod_ruby)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-01-15 21:51 by
Modified: 2005-08-30 02:27 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-01-15 21:51:24
when removing mod_ruby-1.0.2-alt, we have:

httpd: could not open document config file /etc/httpd/conf/addon-modules/mod_ruby.conf
[FAILED]
error: execution of %postun scriptlet from mod_ruby-1.0.2-alt2 failed, exit status 1

this is because at that stage mod_ruby.conf is already mod_ruby.conf.rpmsave if it was modified.
---

---
trickster:~> sudo rpm -e mod_ruby
warning: /etc/httpd/conf/addon-modules/mod_ruby.conf saved as /etc/httpd/conf/addon-modules/mod_ruby.conf.rpmsave
Shutting down httpd: [  OK  ]
Checking configuration sanity for httpd:  [Wed Jan 15 20:46:22 2003] [warn] module mod_php4.c is already added, skipping
fopen: No such file or directory
httpd: could not open document config file /etc/httpd/conf/addon-modules/mod_ruby.conf
[FAILED]
error: execution of %postun scriptlet from mod_ruby-1.0.2-alt2 failed, exit status 1
trickster:~> l /etc/httpd/conf/addon-modules/mod_ruby.conf
/bin/ls: /etc/httpd/conf/addon-modules/mod_ruby.conf: No such file or directory
trickster:~> l /etc/httpd/conf/addon-modules/             
total 5
-rw-r--r--    1 root     root          850 Jan 10 22:45 mod_fastcgi.conf
-rw-r--r--    1 root     root          850 Nov 13 14:47 mod_fastcgi.conf.bak
-rw-r--r--    1 root     root          250 Nov 13 06:06 mod_php4.conf
-rw-r--r--    1 root     root         1337 Dec 17 18:06 mod_ruby.conf.rpmsave

------- Comment #1 From 2003-01-16 11:54:11 -------
duplicate
------- Comment #2 From 2003-01-16 11:54:11 -------
duplicate
------- Comment #3 From 2005-08-30 02:19:40 -------
closing
------- Comment #4 From 2005-08-30 02:27:33 -------
closing