Bug 2027 - different colors with screen(1)
: different colors with screen(1)
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/vim-enhanced)
: unstable
: all Linux
: P4 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-01-21 20:36 by
Modified: 2005-08-30 12:26 (History)


Attachments
0002027-vim-screen.gif (9.57 KB, application/octet-stream)
2003-01-21 20:36, at@altlinux.org
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-01-21 20:36:40
When launched under screen(1), vim gets inappropriate colors for syntax
highlighting. However, colors get normal when env TERM=linux is passed. I
reported on this problem some time ago and it still endures (ALM2.2b).

Here is the screenshot.
left: TERM=linux vim /usr/lib/perl5/find.pl (colors got ok)
right: TERM=screen vim /usr/lib/perl5/find.pl (colors wrong)

I can reproduce this with plain linux console as well is with xterm. Other
programs (say, mutt) do not to have this problem.
---

---
------- Comment #1 From 2003-09-24 19:57:47 -------
Unable to reproduce. Maybe this problem already fixed in upstream?