Bug 20382 - gitk crashes when over ssh -X (BadWindow)
: gitk crashes when over ssh -X (BadWindow)
Status: CLOSED DUPLICATE of bug 19522
: Branch 4.1
(All bugs in Branch 4.1/git)
: unspecified
: all Linux
: P3 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-06-09 14:29 by
Modified: 2010-07-12 18:43 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-06-09 14:29:18
git-1.5.5.5-alt1
tcl-8.5.2-alt1
tk-8.5.2-alt1
openssh-5.0p1-alt3
xorg-server-1.4.2-alt10.M41.1

How to reproduce:

$ ssh 0 -l mort -X
mort@0's password: 
Last login: Tue Jun  9 10:15:30 2009 from localhost.localdomain
[mort@localhost ~]$  cd tmp/tests/
[mort@localhost tests]$  mkdir test-gitk
[mort@localhost tests]$ cd test-gitk/
[mort@localhost test-gitk]$  git init
Initialized empty Git repository in .git/
[mort@localhost test-gitk]$ echo a > a
[mort@localhost test-gitk]$ git add a
[mort@localhost test-gitk]$ git commit -m 'Initial.'
Created initial commit 24562b8: Initial.
 1 files changed, 1 insertions(+), 0 deletions(-)
 create mode 100644 a
[mort@localhost test-gitk]$ gitk
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  7 (X_ReparentWindow)
  Resource id in failed request:  0x74
  Serial number of failed request:  3462
  Current serial number in output stream:  3464
[mort@localhost test-gitk]$ 


In the gitk, I right-clicked on the commit, and went on to add a tag; in the
tag dialog I added the tag name, and clicked on the button "Create".

Result: the tag was created, but gitk crashed. (It seems that such a crash
happens every time a window belonging to gitk is closed. The same error
messages appear when the main window is closed.)

Expected: gitk doesn't crash when some of its windows is closed.
------- Comment #1 From 2009-06-09 14:30:51 -------
This doesn't happen for gitk run immediately in the current X session, and this
doesn't happen when gitk is run under "su - mort". Only over ssh.
------- Comment #2 From 2009-06-09 14:58:24 -------
A lot of programs do not work under "ssh -X".
I'm afraid you have to use "ssh -Y".
------- Comment #3 From 2010-07-12 18:43:45 -------
Thank you for the explanation!
I'm sorry for duplicate posting of this issue.

*** This bug has been marked as a duplicate of bug 19522 ***