Bug 2196 - Add %_pythonlibdir macro
: Add %_pythonlibdir macro
Status: CLOSED DUPLICATE of bug 4815
: Sisyphus
(All bugs in Sisyphus/rpm-build-python)
: unstable
: all Linux
: P5 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-02-09 13:12 by
Modified: 2006-01-18 16:58 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-02-09 13:12:17
The definition would be
%_pythonlibdir %(%__python -c \"from distutils import sysconfig; print sysconfig.get_python_lib()\")

While we are at it, change %__python_version to
%__python_version %(%__python -c \"import sys; print sys.version.split(\' \')[0]\")
Don\'t let anyone know that you are more skilled in shell than in Python ;)
---

---

------- Comment #1 From 2003-02-10 09:17:57 -------
1. Your version  of %__python_version differs from current one:
$ rpm --eval %__python_version
2.2
$ python -c \"import sys; print sys.version.split(\' \')[0]\"
2.2.2
I won\'t change behaviour.

2. Who needs this new macro?
------- Comment #2 From 2003-02-10 09:17:57 -------
1. Your version  of %__python_version differs from current one:
$ rpm --eval %__python_version
2.2
$ python -c \"import sys; print sys.version.split(\' \')[0]\"
2.2.2
I won\'t change behaviour.

2. Who needs this new macro?
------- Comment #3 From 2003-02-11 02:34:56 -------
Agreed, although it would be better to print out the trimmed value
using only Python, e.g.
%(python -c \"import sys, re; print re.match(\'[0-9]+\\.[0-9]+\', sys.version.split(\' \')[0]).group(0)\" 2>/dev/null)
------- Comment #4 From 2003-02-11 02:34:56 -------
Agreed, although it would be better to print out the trimmed value
using only Python, e.g.
%(python -c \"import sys, re; print re.match(\'[0-9]+\\.[0-9]+\', sys.version.split(\' \')[0]).group(0)\" 2>/dev/null)
------- Comment #5 From 2003-02-13 02:58:37 -------
The %_pythonlibdir macro is useful for Python modules installed with help of
distutils (e.g. pretty much every Python module today). Instead of using
inflexible globs like %_libdir/python*/site-packages/, the exact path
could be determined programmatically.
------- Comment #6 From 2003-02-13 02:58:37 -------
The %_pythonlibdir macro is useful for Python modules installed with help of
distutils (e.g. pretty much every Python module today). Instead of using
inflexible globs like %_libdir/python*/site-packages/, the exact path
could be determined programmatically.
------- Comment #7 From 2004-05-17 19:05:21 -------
Andrey?
------- Comment #8 From 2004-05-18 00:59:21 -------
Извините за русский, но с моим локализованным английским ваша продвинутая
версия 
понимается с трудом, тем не менее: 

1. Обратите внимание на то, как %__python_version считается сейчас 

__python_version   %(%__python -c 'import sys; print "%u.%u" %
sys.version_info[0:2]' 
2>/dev/null || echo unknown) 

. Это лучше и шелловских скриптов и каких-то регекспов на питоне.  

2. Чгря слабо понимаю как стыкуется чисто python'вский distutils с rpm-овскими 
макросами, в любом случае, все модули, использованные во время эксперимента на 
дедали ставились с помощью distutils  и отсутствие такой переменной никому 
не мешало. Подробнее см. python-module-SAMPLE.spec. 

3. Если человеку удобен такой макрос - то почему бы не создать, может
пригодится 
если ставить __БЕЗ__ distutils, что иногда приходится делать. 

------- Comment #9 From 2004-06-26 15:38:20 -------
Немного бюрократии.
------- Comment #10 From 2004-06-26 16:27:08 -------
(In reply to comment #9) 
> Немного бюрократии. 
 
Я не против бюрократии, только я не понял, чего предполагается сделать? 
 
------- Comment #11 From 2004-09-11 20:27:06 -------

*** This bug has been marked as a duplicate of 4815 ***