Bug 2198 - \'Западает\' верхняя строчка в less
: \'Западает\' верхняя строчка в less
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/gnome-terminal)
: unstable
: all Linux
: P5 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-02-09 17:41 by
Modified: 2004-06-02 14:16 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-02-09 17:41:06
How to reproduce:
1. Open a text file with less in a gnome-terminal window
2. Make sure that the topmost line of the terminal contains some visible text
3. Exit less
4. Open less again with empty content: cat /dev/null | less
5. The topmost line of the recently viewed text appears again.

This can lead to confusion when an user views an empty file, yet perceives it as containing some text, hence the major severity.

The problem seems to be endemic to gnome-terminal, or more specifically, to the zvt widget. xterm and rxvt do not exhibit such behavior.
---

---
It\'s reproducible on gnome-terminal 2.2.0 and 2.2.1 built with zvt. Gnome-terminal 2.2.1 built with vte, however, does not manifest this problem.
------- Comment #1 From 2004-06-02 14:16:04 -------
fixed