Bug 22340 - Отсутствие жёстких зависимостей на версии библиотек и перевода интерфейса
: Отсутствие жёстких зависимостей на версии библиотек и перевода интерфейса
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/firefox)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2009-11-19 17:06 by
Modified: 2010-02-20 03:24 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-11-19 17:06:10
При точечном обновлении некоторых библиотек и/или firefox'а возможна ситуация,
когда firefox перестаёт работать. Возможна разная симптоматика: тихо не
запускается, не выдавая никаких диагностических сообщений (старый firefox при
обновлённом xulrunner), жалуется на неправильный xml (обновлённый firefox при
старом firefox-ru), жалуется на несоответствие версий sqlite (обновлённый
firefox/libmozsqlite3 при старой libsqlite3). Видимо, в пакете firefox
необходимо проставить более жёсткие зависимости на xulrunner и libsqlite3. Как
быть с переводом, я не знаю, т.к. пакет firefox-ru может стоять, а может и нет,
но если он есть, то его версия должна соответствовать firefox. Если наоборот, в
firefox-ru поставить зависимость на firefox, то что получится при точечном
обновлении firefox? Пакет firefox-ru будет требовать более старую версию, и
приведёт ли это к его автоматическому обновлению или apt ступит и будет
ругаться на невозможность обновления до тех пор, пока ему не укажут, что нужно
обновить и firefox-ru? Хотя даже такой расклад лучше, чем неработающая
программа после обновления.
------- Comment #1 From 2010-02-19 13:51:25 -------
МОжет быть здесь нужно активнее применить нечто типа
Requires: %{get_dep kde4libs}
------- Comment #2 From 2010-02-19 15:17:10 -------
(В ответ на комментарий №1)
> МОжет быть здесь нужно активнее применить нечто типа
> Requires: %{get_dep kde4libs}

Все необходимые зависимости установлены:

$ rpmquery -R firefox-3.6 |grep '[<=>]'
url_handler >= 0.2.1-alt2
libsqlite3 >= 3.6.20-alt1
libnspr >= 4.8.0-alt1
libnss >= 3.12.6.0-alt1.20100116
xulrunner-192 < 1.9.4
xulrunner-192 >= 1.9.2.0

и так уже давно.

На баги ввиде не форматированного потока сознания я не реагирую.
------- Comment #3 From 2010-02-20 03:24:53 -------
(В ответ на комментарий №2)
> Все необходимые зависимости установлены:
...
> и так уже давно.
Значит всё уже решено. Если будут конкретные доказательства, багу можно будет
переоткрыть.