Bug 23306 - install "eterm-color" terminfo, and distribute it separately
: install "eterm-color" terminfo, and distribute it separately
Status: CLOSED WONTFIX
: Branch 4.1
(All bugs in Branch 4.1/emacs22-common)
: unspecified
: all Linux
: P3 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2010-04-09 04:40 by
Modified: 2014-11-05 20:43 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-04-09 04:40:33
emacs22-common-22.2-alt5

Now, the "internal" terminal of Emacs (M-x term) sets TERM value to
"eterm-color", and the Emacs package includes a terminfo entry for this:

    /usr/share/emacs/22.2/etc/e/eterm-color
    /usr/share/emacs/22.2/etc/e/eterm-color.ti
.

Currently, this terminal type is not known to the system terminfo (an older
"eterm" entry is included in terminfo-extra-5.6-alt4, Sisyphus'
terminfo-extra-5.7-alt3, but no "eterm-color").

So, I suggest to install this terminal description to the system terminfo
database.

Also, it would be reasonable to distribute this terminal description in a
separate package, independent of emacs22-common: if one logins from the
internal Emacs terminal to an ALTLinux system without installed Emacs, one
should still be able to find the matching terminfo there. 

And probably make terminfo-extra package dependent on the new package, say,
terminfo-eterm-color, so that "apt-get install terminfo-extra" would pull all
available terminfo's.
------- Comment #1 From 2014-11-05 20:43:18 -------
В 4.1/branch исправления не будут вноситься уже технически (заглушена очередь
на сборку), поэтому прошу ошибки, актуальные для sisyphus/p7/t7, перевесить на
текущие ветки или сизиф.