Bug 23393 - additional menus broken in Emacs
: additional menus broken in Emacs
Status: CLOSED DUPLICATE of bug 22978
: Sisyphus
(All bugs in Sisyphus/emacs-X11)
: unstable
: all Linux
: P3 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2010-04-28 04:20 by
Modified: 2010-04-28 19:08 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-04-28 04:20:33
With the older libgtk+2-2.12.12-alt0.M41.4 (from Branch 4.1) or with
libgtk+2-2.16.6-alt1 (from Branch 5.1), emacs22-X11-gtk-22.2-alt5 (from Branch
4.1) works well: it correctly shows "additional" menus -- added by modes
invoked, as, for example, after you open a directory (C-x C-f), thedired mode
is loaded, and it adds several menus, e.g., "Immediate". So, with the older
libgtk+2, the "Immediate" menu has items shown in it.

But with the newer 2.20.0-alt3 (or libgtk+2-2.18.9-alt1 as well), the added
menu (for example, "Immediate" by the dired mode) are shown empty.

This could be some intentional backward incompatibility of the newer libgtk+2
(then, probably, the soname should be changed) or a bug in the newer libgtk+2.
------- Comment #1 From 2010-04-28 04:28:48 -------
Workaround: use emacs22-X11-athena, for example.
------- Comment #2 From 2010-04-28 06:35:44 -------
This warnings is a warnings, -- please, prepare emacs for gtk-3.0.
------- Comment #3 From 2010-04-28 09:28:32 -------
Говорят (https://bugzilla.altlinux.org/show_bug.cgi?id=22978) что это баг в
самом gtk-коде емакса.
------- Comment #4 From 2010-04-28 19:08:15 -------
Для X11 это неактуально, только для gtk.

*** This bug has been marked as a duplicate of bug 22978 ***