Bug 245 - python has been compiled without LFS
: python has been compiled without LFS
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/python)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2001-12-21 18:31 by
Modified: 2009-05-10 09:31 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2001-12-21 18:31:07
python 2.1.1 has ben compiled without LFS
although it normally supported by python under glibc2.2
---

---
Please, try this:
> f = open(\'/dev/hda\',\'r\')
> f.seek(2000000000L,0)
> f.tell()
returns 2000000000L, but 
> f.seek(3000000000L,0)
cause an error!!! But this should work!
And this works fine when I rebuild Python by myself.
Now I can\'t provide details abount what flags I use because I can\'t remember it. 
But I\'ll do it as soon as I can.
------- Comment #1 From 2002-01-29 19:37:47 -------
It is not true.
Python 2.1.1 has ben compiled with LFS support.
Probably you are using non-LFS filesystem, such as reiserfs-3.5
------- Comment #2 From 2002-01-29 19:37:47 -------
It is not true.
Python 2.1.1 has ben compiled with LFS support.
Probably you are using non-LFS filesystem, such as reiserfs-3.5
------- Comment #3 From 2002-01-30 12:46:25 -------
Python 2.1.1 built with LFS, so it\'s not a bug at all.
------- Comment #4 From 2002-01-30 12:46:25 -------
Python 2.1.1 built with LFS, so it\'s not a bug at all.