Bug 24536 - отсутствует модуль ядра для 2.6.35-std-def-alt7
: отсутствует модуль ядра для 2.6.35-std-def-alt7
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kernel-modules-fglrx-std-def)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2010-11-10 23:54 by
Modified: 2011-01-20 22:53 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-11-10 23:54:29
fglrx_glx

Sisyphus:     8.78.3-alt1

А модуля к нему нет.

прошу собрать.
------- Comment #1 From 2010-11-11 00:05:03 -------
Давайте лучше не будем собирать kernel-modules-fglrx-* для свежих ядер.
------- Comment #2 From 2010-11-11 00:11:20 -------
Почему не будем?
------- Comment #3 From 2010-11-11 00:31:27 -------
действительно, почему ?
------- Comment #4 From 2010-11-11 01:45:36 -------
и что теперь слезать с сизифа?
------- Comment #5 From 2010-11-11 13:52:30 -------
(В ответ на комментарий №4)
> и что теперь слезать с сизифа?
Лучше с ATI. Я слез после R200 и еще ни разу не пожалел.
------- Comment #6 From 2010-11-12 09:12:42 -------
(В ответ на комментарий №5)
> Лучше с ATI. Я слез после R200 и еще ни разу не пожалел.

не надо распространять ATI-боязнь (тем более что ATI более не существует).

надо опираться на официальные данные: http://www.x.org/wiki/RadeonFeature
У автора вопросе серия Evergreen, насколько я понимаю, вероятно в сизифе версия
свободного radeon/mesa/gallium еще не поддерживает эту серию в полной мере.

Но версии в сизифе хорошо поддерживают все карты вплоть до radeon hd 4000
(r600/700 в таблице).

Та что при большом нежелании собирать модуль для fglrx можно посоветовать
собрать последние версии radeon/mesa.
------- Comment #7 From 2010-11-12 10:52:23 -------
(В ответ на комментарий №5)
> (В ответ на комментарий №4)
> > и что теперь слезать с сизифа?
> Лучше с ATI. Я слез после R200 и еще ни разу не пожалел.
Рад за Вас.
Но к сути дела это не меняет.
Я сам предпочитаю nvidia
------- Comment #8 From 2010-11-12 10:53:58 -------
> У автора вопросе серия Evergreen, насколько я понимаю, вероятно в сизифе версия
> свободного radeon/mesa/gallium еще не поддерживает эту серию в полной мере.
> 
> Но версии в сизифе хорошо поддерживают все карты вплоть до radeon hd 4000
> (r600/700 в таблице).
> 
> Та что при большом нежелании собирать модуль для fglrx можно посоветовать
> собрать последние версии radeon/mesa.
+1
Хотя бы так.
------- Comment #9 From 2010-11-12 14:40:00 -------
(In reply to comment #2)
> Почему не будем?

Это проприетарный драйвер, который не работает, и который мы не можем
исправить.
------- Comment #10 From 2010-11-12 15:25:05 -------
nvidia тоже проприетарный драйвер, который иногда не работает.

Если он у кого-то работает, то пусть будет, я не вижу никаких препятствий к
этому.
------- Comment #11 From 2010-11-12 21:53:17 -------
(In reply to comment #9)
> Это проприетарный драйвер, который не работает, и который мы не можем
> исправить.

Тогда логично применять этот подход и к проприетарному драйверу nvidia ;)
(на возражение "а он работает" можно ответить, что модуль fglrx не собран и не
будет, а то ведь он тоже, может, работает ;)
------- Comment #12 From 2010-11-13 00:05:07 -------
(In reply to comment #9)
> (In reply to comment #2)
> > Почему не будем?
> 
> Это проприетарный драйвер, который не работает, и который мы не можем
> исправить.

Ну почему же не работает? Вполне себе работает.

На выходных попробую таки запинать недостающие модули для ядер.
------- Comment #13 From 2010-11-15 21:09:04 -------
> На выходных попробую таки запинать недостающие модули для ядер.

На выходных "запинать" не удалось?

Или там совсем все плохо.

Убунтоиды таки их собрали. Сылку поискать?
------- Comment #14 From 2010-11-15 23:38:37 -------
просто выходные ещё не начались :) Может-завтра-послезавтра
------- Comment #15 From 2010-11-24 20:26:20 -------
(В ответ на комментарий №14)
> просто выходные ещё не начались :) Может-завтра-послезавтра

пинг
------- Comment #16 From 2011-01-19 10:42:27 -------
Уже присутствует (2.6.35-std-def-alt9).
------- Comment #17 From 2011-01-20 22:21:09 -------
(В ответ на комментарий №16)
> Уже присутствует (2.6.35-std-def-alt9).

Ткните носом, пожалуйста:


[root@vostok-home ~]# apt-get update
Получено: 1 http://mirror.yandex.ru i586 release [861B]
Получено: 2 http://mirror.yandex.ru noarch release [859B]
Получено 1720B за 0s (26,7kB/s).

Найдено http://mirror.yandex.ru i586/classic pkglist
Найдено http://mirror.yandex.ru i586/classic release
Найдено http://mirror.yandex.ru noarch/classic pkglist
Найдено http://mirror.yandex.ru noarch/classic release
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
[root@vostok-home ~]# 
[root@vostok-home ~]# apt-cache search fglrx
fglrx-tools - Utilities for ATI/AMD Radeon drivers
fglrx_glx - ATI/AMD Proprietary Linux Display Driver
kernel-source-fglrx-8.80.1 - ATI/AMD fglrx (Radeon video card driver) module
sources
kernel-modules-fglrx-hpc-skif - AMD/ATI Proprietary Linux Display Driver
kernel-modules-fglrx-tmc-tc - AMD/ATI Proprietary Linux Display Driver
------- Comment #18 From 2011-01-20 22:50:29 -------
Тыкаю:
http://prometheus.altlinux.org/ru/Sisyphus/srpms/kernel-modules-fglrx-std-def
------- Comment #19 From 2011-01-20 22:53:58 -------
(В ответ на комментарий №18)
> Тыкаю:
> http://prometheus.altlinux.org/ru/Sisyphus/srpms/kernel-modules-fglrx-std-def

Спасибо, а то на http://sisyphus.ru/ru/find.shtml?request=kernel-modules&page=2

не видно.