Bug 24876 - Не устанавливаются IDE, зависящие от gcc; возможно, из-за проблем с glibc
: Не устанавливаются IDE, зависящие от gcc; возможно, из-за проблем с glibc
Status: CLOSED NOTABUG
: Branch p5
(All bugs in Branch p5/cross-component)
: unspecified
: x86 Linux
: P3 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2011-01-08 17:41 by
Modified: 2011-02-07 03:49 (History)


Attachments
Выход apt-get install при попытке установить glibc (1.07 KB, text/plain)
2011-01-08 17:52, olivertown@mail.ru
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-01-08 17:41:28
На реальной машине установлен ALT Linux Ковчег 5.0 Рабочая станция.
Использовал репозитории p5, rpm, i586 и noarch, classic:
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/p5/branch/

При попытке установить Lazarus или Code::Blocks получаю от Synaptic сообщения:

lazarus:
 Зависит от: glibc-devel
 Зависит от: glib-devel
 Зависит от: gtk+-devel
 Зависит от: libgtk+2-devel

codeblocks:
 Зависит от: gcc
 Зависит от: gcc-c++

Попытался установить какие-нибудь из этих пакетов разных версий, чтобы
посмотреть, что же там мешает. Результат таков:

gtk+-devel:
 Зависит от: glib-devel
 Зависит от: pkgconfig(glib)

gcc4.3-c++:
 Зависит от: gcc4.3 (= 4.3.2-alt13)
 Зависит от: libstdc++4.3-devel (= 4.3.2-alt13)
 Зависит от: /usr/share/man/man1/gcc-4.3.1.bz2

gcc4.4:
 Зависит от: glibc-devel

libstdc++4.4-devel:
 Зависит от: glibc-devel

glib-devel:
 Зависит от: glibc-devel

glibc-devel:
 Зависит от: glibc (= 6:2.11.2-alt1.M51.1)

По-видимому, всё сходится ко glibc. При попытке поставить glibc получаю
предложение снести пол-системы, включая ConsoleKit, DeviceKit, GConf,
PolicyKit, alacarte, alterator... и множество прикладного ПО.

Возможно, дело в том, что с установкой glibc (=6:2.11.2-alt1.M51.1)
"устаревают" пакеты libc-static и libc-devel. Но чем они заменяются?

Добавил к репозиториям такие же для веток 5.0 и 5.1:
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/5.0/branch/
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/5.1/branch/

Обновил всю систему (кроме libschroedinger, но она здесь явно не при чём). Это
не помогло. Убрал из списка репозиториев всё, кроме 5.1. Тоже не помогло, всё
по-прежнему.

В результате из серьёзных IDE удалось поставить только Qt Creator.
------- Comment #1 From 2011-01-08 17:52:19 -------
Created an attachment (id=4740) [details]
Выход apt-get install при попытке установить glibc
------- Comment #2 From 2011-01-09 04:33:59 -------
(В ответ на комментарий №0)
> На реальной машине установлен ALT Linux Ковчег 5.0 Рабочая станция.
> Использовал репозитории p5, rpm, i586 и noarch, classic:
> ftp://ftp.altlinux.org/pub/distributions/ALTLinux/p5/branch/
> 
> При попытке установить Lazarus или Code::Blocks получаю от Synaptic сообщения:

Мне на свежеустановленном ковчеге воспроизвести не удалось. Установил,
подключил репы p5 (о, мысль, а cdrom из списка обновлений убран? он может
мешать) сделал apt-get update. После этого и codeblocks и lazarus поставились
без проблем. Часть пакетов проапгрейдилась автоматом (и glibc в том числе).
Вообще ничего не сносилось.

> Возможно, дело в том, что с установкой glibc (=6:2.11.2-alt1.M51.1)
> "устаревают" пакеты libc-static и libc-devel. Но чем они заменяются?

Возможно. Это примерные названия пакетов или точные? Если точные, то откуда они
у вас?

> Добавил к репозиториям такие же для веток 5.0 и 5.1:
> ftp://ftp.altlinux.org/pub/distributions/ALTLinux/5.1/branch/
Это зря.
> ftp://ftp.altlinux.org/pub/distributions/ALTLinux/5.0/branch/
А это тем более зря.

> Обновил всю систему (кроме libschroedinger, но она здесь явно не при чём). Это
> не помогло. Убрал из списка репозиториев всё, кроме 5.1. Тоже не помогло, всё
> по-прежнему.
Теперь какая-то смесь получилась из p5 и 5.1. Но думаю, что и она может быть
вполне работоспособной, если аккуратно разобраться с проблемой.

Итак. Первое - убедится что в списках репо нет cdrom'а
Обычно он в
/etc/apt/sources.list.d/sources.list
или
/etc/apt/sources.list

Далее, оставить только один репозиторий (5.1, так 5.1). Не забыть apt-get
update
А затем пытаться подсунуть apt-get пакеты, которые надо установить, пакеты,
которые он требует по зависимостям и пакеты, которые он хочет снести. Ну а
дальше уж смотреть вывод. 
P.S. Есть ещё "секретная" опция для apt-get: -o Debug::pkgProblemResolver=1
Но поможет ли она чем-нибудь здесь - не знаю.
------- Comment #3 From 2011-01-09 05:03:18 -------
А вообще, первым делом покажите вывод команды:
grep -R '^\s*rpm' /etc/apt
------- Comment #4 From 2011-01-09 14:30:06 -------
Команда на демонстрацию репозиториев:
grep -R '^\s*rpm' /etc/apt

Дала следующий выход:
/etc/apt/sources.list:rpm
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/5.1/branch/ i586 classic 
/etc/apt/sources.list:rpm
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/5.1/branch/ noarch classic 

Думаю, когда всё только начиналось, там были бы /p5/branch/
В /etc/apt/sources.list есть только эти 5.1. и закомментаренные 5.0. Хм. И
закоментаренный Сизиф. Кажется, я понял, где собака зарыта... Только не понял,
когда и зачем.

В каталоге /etc/apt/sources.list.d/ несколько файлов, в них все источники
закомментарены. В частности, в самом sources.list закомментарен CD-ROM:
# rpm cdrom:[ALT Linux 5.0.0 Ark Desktop  (none) main build 2009-10-26]/
ALTLinux main 

Его я первым делом убрал из репозиториев после установки системы.

Точны ли названия пакетов - не знаю. Synaptic пишет, что они obsoletes в
свойствах glibc. Найти их как таковые в списках пакетов или в зависимостях того
же GConf я не смог, хотя в последних есть строки вроде libc.so.6 (=GLIBC....).

Сейчас применю apt-get update и dist-upgrade, о результатах напишу.
------- Comment #5 From 2011-01-10 00:44:58 -------
После downgrade'а всё поставилось.
------- Comment #6 From 2011-02-07 03:49:03 -------
Будем считать, что проблема была локальной, а ошибки пока не было.