Bug 24995 - doesn't send accented Latin letters to multitran
: doesn't send accented Latin letters to multitran
Status: CLOSED WONTFIX
: Branch 4.1
(All bugs in Branch 4.1/emacs-w3m)
: unspecified
: all Linux
: P3 normal
Assigned To:
:
: http://multitran.ru
:
:
:
  Show dependency tree
 
Reported: 2011-01-30 01:57 by
Modified: 2014-11-05 20:43 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-01-30 01:57:48
emacs22-common-22.2-alt5
emacs-w3m-1.4.259-alt0.2.20080303
w3m-0.5.2-alt1

If one wants to query the French dictionary at http://multitran.ru with a
word with accents, emacs-w3m warns and doesn't send the accented
letters. (This doesn't allow to use effectively the dictionary,
because accents are important: there are pairs of words that differ only by an
accent, and an
attempt to 
simply send the same query with no accented letters will lead to a
different word.)

At the same time, querying with Russian words works.

How to reproduce:

M-x w3m

g http://multitran.ru

In the query form, select French and write a word with accents, for
example, "dès" (you can type it after setting an appropriate input
method like this one: 
C-x RET C-\ french-prefix; then you switch to French with C-\ in the
minibuffer and type: d`es).

Emacs warns: 
"è" would not be accepted. Continue? (y or n)
.

Then you submit the form, and multitran receives a wrong query
("d?s").

Expected behavior:

It is possible in other browsers, say,
chromium-browser-7.0.513.0-alt1.r58159 -- so it's not a problem of
multitran.ru:
you can paste "dès" into the field in Chromium, and the query is
submitted correctly.
------- Comment #1 From 2014-11-05 20:43:26 -------
В 4.1/branch исправления не будут вноситься уже технически (заглушена очередь
на сборку), поэтому прошу ошибки, актуальные для sisyphus/p7/t7, перевесить на
текущие ветки или сизиф.