Bug 2578 - derive the value for user\'s charset from locale
: derive the value for user\'s charset from locale
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/pine)
: unstable
: all Linux
: P5 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-05-11 19:58 by
Modified: 2006-12-06 18:40 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-05-11 19:58:50
Now it is set in ~/.pinerc by character-set.

The problem is in mapping the system coding names to MIME charset names, e.g., for ru_RU.CP1251 Pine should use \"windows-1251\".
---

---
pine-4.55L-alt2

A common library for such mapping would be a good solution. It could re-use a small piece of code from librecode (that deals with aliases and stores additional info about the coding systems).

Emacs has such a map (by means of a property in coding-systems definitoons).

------- Comment #1 From 2006-09-27 22:22:39 -------
reassign
------- Comment #2 From 2006-09-28 16:36:16 -------
assigned
------- Comment #3 From 2006-11-02 18:21:41 -------
fixed in pine 4.64.

but you should remove charset from .pinerc if you have entry there.
------- Comment #4 From 2006-12-06 18:40:40 -------
closed