Bug 26215 - usershares does not work with latest samba version
: usershares does not work with latest samba version
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/thunar-shares-plugin)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2011-09-01 21:22 by
Modified: 2011-09-02 17:41 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-09-01 21:22:00
Usershares does not work with latest samba version. All configured ok, worked
with 3.5.9, with 3.6.0 it does not work. All the options are greyed out.
If i manually add the share (in a textfile) in /var/lib/samba/usershares/, it
is shared, so it is not a samba issue.

Also, if I use net usershare add/delete, it works fine.
------- Comment #1 From 2011-09-02 16:15:35 -------
I can't reproduce this.

$ rpm -q samba  
samba-3.6.0-alt1

> All the options are greyed out.

There should be some additional message if something goes wrong.
Are you sure that smb and nmb services is up?

> Also, if I use net usershare add/delete, it works fine.

Very strange, thunar's plugin just uses the same commands, there are no any
other magic.
------- Comment #2 From 2011-09-02 17:41:57 -------
[alecs@rainsoul ~]$ rpm -qa | grep -E 'samba-3|thunar-shares'
thunar-shares-plugin-0.2.1-alt1.git20110411
samba-3.6.0-alt1
[alecs@rainsoul ~]$ groups 
alecs wheel fuse vboxusers hashman alecs_a alecs_b sambashare
[alecs@rainsoul ~]$ net usershare list '*'
torrents
muu
current2
movies
dan

It says: You may need to install samba, check your user permissions (usershare
group) and re-login.
I also tried giving 777 to /var/lib/samba/usershares 
Also, with nautilus-share it works.


SOLUTION:
[alecs@rainsoul ~]$ net conf list
Failed to initialize the registry: WERR_ACCESS_DENIED
[root@rainsoul alecs]# ls -la /var/lib/samba/registry.tdb 
-rw------- 1 root root 81920 Sep  1 17:13 /var/lib/samba/registry.tdb
[root@rainsoul alecs]# chgrp sambashare /var/lib/samba/registry.tdb
[root@rainsoul alecs]# chmod 660 /var/lib/samba/registry.tdb
[root@rainsoul alecs]# ls -la /var/lib/samba/registry.tdb 
-rw-rw---- 1 root sambashare 81920 Sep  1 17:13 /var/lib/samba/registry.tdb

Works for me now.