Bug 2706 - gpm doesnot work
: gpm doesnot work
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/screen)
: unstable
: all Linux
: P4 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-06-26 17:40 by
Modified: 2012-03-16 13:57 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-06-26 17:40:13
Mouse events do not work when programs run under screen.  It  acts as a mere
text selection.

---

---
------- Comment #1 From 2003-08-28 15:20:54 -------
It's now your bug, not mine. :) 
------- Comment #2 From 2003-09-22 15:40:16 -------
Actually it never worked.  Screen never featured this feature.  Here is the
explanation: http://groups.yahoo.com/group/gnu-screen/message/496

But let it be your bug again. :)  There's a patch for gpm that does some
trickery.
http://lists.linux.it/pipermail/gpm/2000-November/thread.html

------- Comment #3 From 2003-09-22 16:00:55 -------
One more href: 
http://lists.linux.it/pipermail/gpm/2001-October/000121.html 
------- Comment #4 From 2005-04-17 18:03:00 -------
*** Bug 5901 has been marked as a duplicate of this bug. ***
------- Comment #5 From 2008-01-30 18:17:26 -------
Folks in debian-russian@ noted that elinks under screen actually does work with
mouse events (verified on M24; indeed).

Would be nice if at least exactly vim could do it too..... (:set mouse=a and
scroll to understand me :)