Bug 28834 - check-nvr ERROR: can't update E.
: check-nvr ERROR: can't update E.
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/sisyphus_check)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2013-04-10 22:35 by
Modified: 2015-11-13 13:12 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-04-10 22:35:03
E в какой-то момент перестал быть позволенным именем пакета:
в autoimports есть E-1.6-alt1_1.src.rpm от Авг 27  2012
но собрать E-1.7 уже не получается:
hsh OUT/E-1.7-alt1_1.src.rpm
...
/usr/src/in/srpm/E-1.7-alt1_1.src.rpm: invalid package NAME: E
sisyphus_check: check-nvr ERROR: package name-version-release format violation
hsh-rebuild: E-1.7-alt1_1.src.rpm: sisyphus_check failed.

%description
E is a purely equational theorem prover for full first-order logic.
That means it is a program that you can stuff a mathematical
specification (in first-order format) and a hypothesis into, and which
will then run forever, using up all of your machines' resources.  Very
occasionally it will find a proof for the hypothesis and tell you so.

E's inference core is based on a modified version of the superposition
calculus for equational clausal logic.  Both clausification and
reasoning on the clausal form can be documented in checkable proof
objects.

E was the best-performing open source software prover in the 2008 CADE
ATP System Competition (CASC) in the FOF, CNF, and UEQ divisions.  In
the 2011 competition, it won second place in the FOF division, and
placed highly in CNF and UEQ.
------- Comment #1 From 2015-11-13 13:12:05 -------
sisyphus_check-0.8.40-alt1 -> sisyphus:

* Fri Nov 13 2015 Dmitry V. Levin <ldv@altlinux> 0.8.40-alt1
- 090-check-nvr (check_nvr):
  + allowed single symbol package names (closes: #28834, #31481).