Bug 30440 - tortoisehg and tortoisehg-nautilus packages are missed in ALT Linux p7
: tortoisehg and tortoisehg-nautilus packages are missed in ALT Linux p7
Status: CLOSED FIXED
: New/proposed packages
(All bugs in New/proposed packages/В Autoimports)
: не указана
: all Linux
: P3 normal
Assigned To:
:
:
:
: 31690
:
  Show dependency tree
 
Reported: 2014-11-02 21:41 by
Modified: 2018-12-18 15:08 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2014-11-02 21:41:07
If it possible please compile and upload tortoisehg and tortoisehg-nautilus
packages (with Python development ones) to Sisyphus and then to ALT Linux p7.

According to pkgs.org (http://pkgs.org/search/tortoisehg-nautilus)
tortoisehg-nautilus package is available in Debian, Ubuntu, Fedora, Mageia,
OpenMandriva, ROSA, but not in ALT Linux.

These packages are very useful for developing and supporting Mercurial
projects.
------- Comment #1 From 2016-01-09 00:59:01 -------
tortoisehg-nautilus - дело сомнительное, по крайней мере для KDesktop. Nautilus
- это проводник GNOME. Для Dolphin же такого плагина вообще нет.

А вот сам tortoisehg полезен и пришлось его ставить самому ради скрипта thg.
Скрипт позволяет работать визуально с репозитарием (современные версии очень
хорошо это делают). Да, приходится вводить в консоли в папке репозитария такие
команды как `thg log` но это лучше, чем ничего.
------- Comment #2 From 2018-06-29 18:10:52 -------
Перевешиваю с p7 на New/proposed packages.
------- Comment #3 From 2018-11-08 15:51:19 -------
(В ответ на комментарий №0)
> If it possible please compile and upload tortoisehg and tortoisehg-nautilus
> packages (with Python development ones) to Sisyphus and then to ALT Linux p7.

I suppose, that anyway it wont be uploaded in p7 branch, because it's not
supported. So question is about Sisyphus and p8 only.
------- Comment #4 From 2018-11-08 17:53:23 -------
tortoisehg я импортирую без проблем, но он не проходит тест на unmets

i586 hsh /tmp/.private/viy/hasher1.i586 --number 1 --target=i586
--apt-config=/home/viy/.autorepo/apt/apt.conf.i586
OUT/tortoisehg-4.6.1-alt1_1.src.rpm
x86_64 hsh /tmp/.private/viy/hasher1.x86_64 --number 1 --target=x86_64
--apt-config=/home/viy/.autorepo/apt/apt.conf.x86_64
OUT/tortoisehg-4.6.1-alt1_1.src.rpm
+Package tortoisehg version 4.6.1-alt1_1 has an unmet dep:
+ Depends: python2.7(_winreg)
+ Depends: python2.7(comtypes)
+ Depends: python2.7(pythoncom)
+Package tortoisehg version 4.6.1-alt1_1 has an unmet dep:
+ Depends: python2.7(_winreg)
+ Depends: python2.7(comtypes)
+ Depends: python2.7(pythoncom)
unmets test failed.
tortoisehg is moved to /home/viy/TASK.UGLY
autorepo-parallel-build -d -j 16  165,13s user 27,29s system 94% cpu 3:22,94
total

для него надо дособрать питоньих модулей.
------- Comment #5 From 2018-11-08 17:59:58 -------
(В ответ на комментарий №4)
> tortoisehg я импортирую без проблем, но он не проходит тест на unmets
> для него надо дособрать питоньих модулей.

Я только что отправил в сизиф. В базовой комплектации он работает. По крайней
мере мне его функциональности достаточно.
------- Comment #6 From 2018-11-09 12:30:43 -------
(В ответ на комментарий №0)
> If it possible please compile and upload tortoisehg and tortoisehg-nautilus
> packages (with Python development ones) to Sisyphus and then to ALT Linux p7.

> These packages are very useful for developing and supporting Mercurial
> projects.

You can try to use tortoisehg from Sisyphus repo. If it's functionality will be
not as full as needed, write here please. I suppose, that in p8 it can be
backported some monthes futher.
------- Comment #7 From 2018-12-18 15:08:17 -------
[#217730] p8 DONE (try 3) tortoisehg.git=4.8.1-alt1

Теперь с чистой душой закрываю баг, поскольку thg имеется и в сизифе и в p8.
Плагин для наутилуса не появится, поскольку апстрим, кажется забил на его
разработку. По крайней мере мне не удалось найти рабочего рецепта его запуска.