Bug 3204 - SIGSEGV in grip's editor at the very first cyrillic character
: SIGSEGV in grip's editor at the very first cyrillic character
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/grip)
: unstable
: all Linux
: P1 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-10-27 10:17 by
Modified: 2006-01-03 00:56 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-10-27 10:17:28
When trying to edit any disc data, grip-3.1.2 would crash just as you try to
enter a cyrillic character (XKB enabled).  It doesn't depend on locale
completeness (I tend to use partially C locale but "LC_ALL=ru_RU.KOI8-R grip"
yields the same result) either.  It doesn't also depend on whether disc is
already "known" or not.
------- Comment #2 From 2003-10-27 19:43:23 -------
Also can't reproduce it here. Maybe a backtrace will help 
------- Comment #3 From 2003-10-28 10:47:56 -------
Caught it.  Diff between ~/.grip that would do segfault and the one that
wouldn't:

-discdb_encoding ANSI_X3.4-1968
-fs_encoding ANSI_X3.4-1968
-id3_encoding ANSI_X3.4-1968
+discdb_encoding KOI8-U
+fs_encoding KOI8-U
+id3_encoding KOI8-U

It seems that at some stage I've got misconfigured default values for these (no
I didn't enter them, just didn't touch at all on the system where grip would
crash).

Seems *now* the defaults are fixed, but it would be reasonable to do some kind
of sanity check regarding whether the conversion is successful.
------- Comment #4 From 2004-03-25 19:40:18 -------
fixed, thanks to Sergey Pinaev (dfo@)