Bug 3246 - pppd падает с segfault'ом при использовании опции dump и pptp-туннеля
: pppd падает с segfault'ом при использовании опции dump и pptp-туннеля
Status: CLOSED DUPLICATE of bug 1588
: Sisyphus
(All bugs in Sisyphus/ppp)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-11-08 19:49 by
Modified: 2005-09-04 18:04 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-11-08 19:49:13
При попытке отладки работы pptp-клиента, понадобилось использовать вызов pppd
как pppd call pptp dump (pptp - дефолтовое имя peer'а туннеля). Результат -
стабильный segmentation fault.

Steps to Reproduce:
1. Установить pptp туннель путем pptp-config
2. pppd call pptp dump

Actual Results:  
pppd options in effect:
debug           # (from /etc/ppp/peers/pptp)
dump            # (from command line)
noauth          # (from /etc/ppp/options)
name greycat            # (from /etc/ppp/peers/pptp)
remotename PPTP         # (from /etc/ppp/peers/pptp)
                # (from /etc/ppp/options)
connect /bin/true               # (from /etc/ppp/peers/pptp)
pty /usr/sbin/pptp 192.168.0.250 --nolaunchpppd         # (from
/etc/ppp/peers/pptp)
Segmentation fault


Expected Results:  
это же самое, без Segmentation fault и дальнейшая нормальная работа pppd
------- Comment #1 From 2003-11-09 02:58:30 -------

*** This bug has been marked as a duplicate of 1588 ***