Bug 33830 - Не хватает зависимости на libglut.so.3
: Не хватает зависимости на libglut.so.3
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/cura)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2017-08-30 10:08 by
Modified: 2017-12-13 11:08 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2017-08-30 10:08:09
Не запускается, если не установлен пакет libGLUT или libfreeGLUT,
предоставляющие провайдес libglut.so.3:

cura
load preferences from /home/altlinux/.cura/15.04.4/preferences.ini
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/_core.py",
line 14666, in <lambda>
    lambda event: event.callable(*event.args, **event.kw) )
  File "/usr/lib/python2.7/site-packages/Cura/gui/splashScreen.py", line 15, in
DoCallback
    self.callback()
  File "/usr/lib/python2.7/site-packages/Cura/gui/app.py", line 103, in
afterSplashCallback
    from Cura.gui import mainWindow
  File "/usr/lib/python2.7/site-packages/Cura/gui/mainWindow.py", line 17, in
<module>
    from Cura.gui import sceneView
  File "/usr/lib/python2.7/site-packages/Cura/gui/sceneView.py", line 28, in
<module>
    from Cura.gui.util import previewTools
  File "/usr/lib/python2.7/site-packages/Cura/gui/util/previewTools.py", line
12, in <module>
    from Cura.gui.util import openglHelpers
  File "/usr/lib/python2.7/site-packages/Cura/gui/util/openglHelpers.py", line
17, in <module>
    glutInit() #Hack; required before glut can be called. Not required for all
OS.
  File "/usr/lib/python2.7/site-packages/OpenGL/GLUT/special.py", line 333, in
glutInit
    _base_glutInit( ctypes.byref(count), holder )
  File "/usr/lib/python2.7/site-packages/OpenGL/platform/baseplatform.py", line
407, in __call__
    self.__name__, self.__name__,
OpenGL.error.NullFunctionError: Attempt to call an undefined function glutInit,
check for bool(glutInit) before calling

Прошу добавить пропущенную зависимость на libglut.so.3
------- Comment #1 From 2017-12-13 11:08:18 -------
Для версии 2.4 это не актуально, libglut.so.3 для работы не нужна. В p8 баг
исправлен. Закрываю как notabug.