Bug 3398 - breaks ALM2.2->Sisyphus upgrade!
: breaks ALM2.2->Sisyphus upgrade!
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libgda)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-12-22 14:04 by
Modified: 2005-08-30 02:32 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-12-22 14:04:59
this package breaks pristine ALM2.2 -> Sisyphus (2003121x tested) dist-upgrade.

Steps to Reproduce:
1. install ALM2.2 (having libgda)
2. attempt to dist-upgrade to Sisyphus
3.
Actual Results:  
> Preparing...
> ##########################################################################
> [100%]
> package libgda-0.2.96-alt3 is already installed
> file /usr/lib/libgda-client.so.0.0.0 from install of libgda-0.2.96-alt3
> conflicts with file from package libgda-0.2.96-alt3
> file /usr/lib/libgda-clientcpp.so.0.0.0 from install of
> libgda-0.2.96-alt3 conflicts with file from package libgda-0.2.96-alt3
> file /usr/lib/libgda-common.so.0.0.0 from install of libgda-0.2.96-alt3
> conflicts with file from package libgda-0.2.96-alt3
> file /usr/lib/libgda-server.so.0.0.0 from install of libgda-0.2.96-alt3
> conflicts with file from package libgda-0.2.96-alt3
> E: Sub-process /bin/rpm returned an error code (106)

after this apt-get would segfault until /var/cache/apt/pkgcache.bin is removed.


Expected Results:  
clean upgrade
------- Comment #1 From 2004-01-28 17:05:32 -------
пересобрать с увеличением релиза?
------- Comment #2 From 2004-03-09 11:50:34 -------
fixed in libgda-0.2.96-alt4
------- Comment #3 From 2005-08-30 02:22:26 -------
closing
------- Comment #4 From 2005-08-30 02:32:29 -------
closing