Bug 3414 - g++/g77 is required for every program which uses AC_PROG_LIBTOOL
: g++/g77 is required for every program which uses AC_PROG_LIBTOOL
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libtool_1.5)
: unstable
: all Linux
: P5 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-12-29 01:08 by
Modified: 2008-05-27 02:07 (History)


Attachments
libtool-bug.spec (901 bytes, text/plain)
2003-12-29 01:09, Dmitry V. Levin
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-12-29 01:08:05
AC_PROG_LIBTOOL expands to the code wich always checks for g++/g77 and its 
preprocessors. 
In gcc-3.3 series, preprocessor tries to use the corresponding driver, which results 
to failure if g++/g77 is not installed. 
That is, after upgrading to gcc-3.3.2, both g++ and g77 are strongly 
required for every program which uses AC_PROG_LIBTOOL. 
 
I suppose bug in AC_PROG_LIBTOOL. 

Steps to Reproduce:
1. rpmbuild -bs libtool-bug.spec 
2. hsh /path/to/workdir ~/RPM/SRPMS/libtool-bug-0.0.1-alt1.src.rpm
------- Comment #1 From 2003-12-29 01:09:31 -------
Created an attachment (id=325) [details]
libtool-bug.spec
------- Comment #2 From 2003-12-29 01:12:26 -------
This behaviour delays upgrading gcc to 3.3.x in Sisyphus. 
------- Comment #3 From 2003-12-29 15:04:13 -------
Fixed in libtool_1.5-1.5-alt11 
------- Comment #4 From 2004-02-04 22:14:04 -------
This fix (libtool-1.5-alt-tagconfig-deps.patch) causes unwanted side effect - 
libtool behaviour depends on configure.ac lines order: 
with this patch applied, the AC_PROG_LIBTOOL line must go after AC_PROG_CXX and 
AC_PROG_F77, otherwise no proper tag configs will be generated. 
 
So I'm disabling the patch and reopening the bug. 
 
It is no longer block due to fix in autoconf_2.5-2.59-alt2. 
------- Comment #5 From 2004-11-28 04:39:21 -------
In libtool_1.5-1.5.10-alt1 this g++/g77 scan failure no longer leads to an
error.