Bug 3533 - 'requires' wrong version: 2.60 instead of 2.62
: 'requires' wrong version: 2.60 instead of 2.62
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/perl-Mail-SpamAssassin)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-01-22 00:26 by
Modified: 2005-09-04 22:22 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-01-22 00:26:21
Actual Results:  
$ cat email | sa-learn --spam
configuration file "/usr/share/spamassassin/20_body_tests.cf" requires version
2.60 of SpamAssassin, but this is code version 2.62. Maybe you need to use the
-C switch, or remove the old config files? Skipping this file at
/usr/lib/perl5/vendor_perl/Mail/SpamAssassin/Conf.pm line 362.
configuration file "/usr/share/spamassassin/20_compensate.cf" requires version
2.60 of SpamAssassin, but this is code version 2.62. Maybe you need to use the
-C switch, or remove the old config files? Skipping this file at
/usr/lib/perl5/vendor_perl/Mail/SpamAssassin/Conf.pm line 362.
configuration file "/usr/share/spamassassin/20_dnsbl_tests.cf" requires version
2.60 of SpamAssassin, but this is code version 2.62. Maybe you need to use the
-C switch, or remove the old config files? Skipping this file at
/usr/lib/perl5/vendor_perl/Mail/SpamAssassin/Conf.pm line 362.
configuration file "/usr/share/spamassassin/20_fake_helo_tests.cf" requires
version 2.60 of SpamAssassin, but this is code version 2.62. Maybe you need to
use the -C switch, or remove the old config files? Skipping this file at
/usr/lib/perl5/vendor_perl/Mail/SpamAssassin/Conf.pm line 362.
configuration file "/usr/share/spamassassin/20_head_tests.cf" requires version
2.60 of SpamAssassin, but this is code version 2.62. Maybe you need to use the
-C switch, or remove the old config files? Skipping this file at
/usr/lib/perl5/vendor_perl/Mail/SpamAssassin/Conf.pm line 362.
configuration file "/usr/share/spamassassin/20_html_tests.cf" requires version
2.60 of SpamAssassin, but this is code version 2.62. Maybe you need to use the
-C switch, or remove the old config files? Skipping this file at
/usr/lib/perl5/vendor_perl/Mail/SpamAssassin/Conf.pm line 362.
configuration file "/usr/share/spamassassin/20_meta_tests.cf" requires version
2.60 of SpamAssassin, but this is code version 2.62. Maybe you need to use the
-C switch, or remove the old config files? Skipping this file at
/usr/lib/perl5/vendor_perl/Mail/SpamAssassin/Conf.pm line 362.
configuration file "/usr/share/spamassassin/20_phrases.cf" requires version 2.60
of SpamAssassin, but this is code version 2.62. Maybe you need to use the -C
switch, or remove the old config files? Skipping this file at
/usr/lib/perl5/vendor_perl/Mail/SpamAssassin/Conf.pm line 362.
configuration file "/usr/share/spamassassin/20_porn.cf" requires version 2.60 of
SpamAssassin, but this is code version 2.62. Maybe you need to use the -C
switch, or remove the old config files? Skipping this file at
/usr/lib/perl5/vendor_perl/Mail/SpamAssassin/Conf.pm line 362.
configuration file "/usr/share/spamassassin/20_uri_tests.cf" requires version
2.60 of SpamAssassin, but this is code version 2.62. Maybe you need to use the
-C switch, or remove the old config files? Skipping this file at
/usr/lib/perl5/vendor_perl/Mail/SpamAssassin/Conf.pm line 362.
configuration file "/usr/share/spamassassin/23_bayes.cf" requires version 2.60
of SpamAssassin, but this is code version 2.62. Maybe you need to use the -C
switch, or remove the old config files? Skipping this file at
/usr/lib/perl5/vendor_perl/Mail/SpamAssassin/Conf.pm line 362.
Learned from 1 message(s) (1 message(s) examined).


Expected Results:  
$ cat email | sa-learn --spam
Spammer is doomed ;-)
------- Comment #1 From 2004-01-27 19:50:40 -------
Last update works