Bug 3972 - Unable to debug threads
: Unable to debug threads
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/gdb)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-04-14 13:06 by
Modified: 2007-03-31 21:42 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-04-14 13:06:43
With GDB 6.1, support for threads seems to be broken (not that I checked this
functionality in earlier versions). When I run a multithreaded program such as
Nautilus, I cannot switch to other threads nor even list them. gdb gets stuck
with an error.

(gdb) info threads
  8 Thread 6151 (LWP 2875)  Couldn't get registers: No such process.
(gdb) thread 2
Couldn't get registers: No such process.
(gdb) bt
Couldn't get registers: No such process.
------- Comment #1 From 2004-04-15 20:16:13 -------
Unable to reproduce, please provide more information. 
------- Comment #2 From 2004-04-16 12:31:33 -------
I run nautilus under gdb; I break (with Ctrl-C) when it freezes on actions
described here:

http://bugzilla.gnome.org/show_bug.cgi?id=139900

After that, 'info threads' results in the error.
If I break execution outside of the hangup, 'info threads' proceeds without errors.
------- Comment #3 From 2007-03-31 21:42:12 -------
The problem should gone with update to gdb-6.6-alt1.
Please reopen if not.