Bug 4031 - new option for stty: iutf8
: new option for stty: iutf8
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/coreutils)
: unstable
: all Linux
: P2 normal
Assigned To:
:
: http://mail.gnu.org/archive/html/bug-...
:
:
:
  Show dependency tree
 
Reported: 2004-04-25 18:16 by
Modified: 2008-06-13 12:15 (History)


Attachments
I modified the spec file like this. (1.78 KB, patch)
2004-04-25 18:20, Ivan Zakharyaschev
no flags Details | Diff
I modified the spec file like this. (1.92 KB, patch)
2004-04-25 18:23, Ivan Zakharyaschev
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-04-25 18:16:06
In linux 2.6.5 (mainstream) and in kernel-feat-drivers-console-unicode,
IUTF8 bit has been introduced to the terminal settigns. (It makes kernel line editing mode respect UTF-8 multibyte characters.)
stty should be able to modify this bit (by iutf8 option).

Both changes (to the kernel and to stty) were suggested by Bruno Haible: ftp://ftp.ilog.fr/pub/Users/haible/utf8/
------- Comment #1 From 2004-04-25 18:20:28 -------
Created an attachment (id=395) [details]
I modified the spec file like this.

The problem is that the IUTF8 value should be defined in the kernel headers.
But the default kernel headers might not define it.
So, a solution is required that will use the "right" kernel headers (with
IUTF8) when coreutils is built.
Such right kernel headers are thos from 2.6.5 or patched.
------- Comment #2 From 2004-04-25 18:23:36 -------
Created an attachment (id=396) [details]
I modified the spec file like this.

The patch to the source. The inclusion of the specific kernel headers is wrong.
------- Comment #3 From 2004-04-25 18:28:11 -------
I'm about to use the patch applied to coreutils cvs.
------- Comment #4 From 2004-04-25 20:03:40 -------
JFYI, the IUTF8 value is defined in fresh glibc headers.
------- Comment #5 From 2004-04-25 20:31:04 -------
Implemented in coreutils-5.2.1-alt4.
Requires glibc headers from glibc snapshot 2004-03-30 or later.