Bug 4081 - freeciv-client-gtk2 should require freeciv-client
: freeciv-client-gtk2 should require freeciv-client
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/freeciv-client-gtk2)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-05-03 14:17 by
Modified: 2005-07-13 15:46 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-05-03 14:17:53
civclient fails to run without common files in freeciv-client.

Steps to Reproduce:
apt-get install freeciv-client-gtk2
Actual Results:  
$ civclient
1: Did not read help texts
0: No useable default tileset found, aborting!
------- Comment #1 From 2004-05-03 18:33:14 -------
BTW, this package (freeciv-client-gtk2) is not exepected to be installed by
hand.

You suggest to introduce dependency loop, right?
------- Comment #2 From 2004-05-03 23:17:40 -------
OK, sorry, guess this one is an INVALID bug then.
(Still, 'apt-get install freeciv' installs freeciv-client-xaw3d, which is IMHO
unlikely to be what the user wants; but that's probably difficult to overcome.)
------- Comment #3 From 2004-05-03 23:19:59 -------
I'll probably disable packaging freeciv-client-xaw3d by default.