Bug 4158 - dhcpcd.exe doesn't check file existance before sourcing
: dhcpcd.exe doesn't check file existance before sourcing
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/dhcpcd)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-05-14 13:10 by
Modified: 2005-08-30 02:28 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-05-14 13:10:53
/etc/dhcpc/dhcpcd.exe (line 27) doesn't check whether file it tries to source
exists.  It leads to spurious messages when DHCP server isn't reachable.
------- Comment #1 From 2004-05-22 13:57:44 -------
*** Bug 4210 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2004-06-03 20:27:45 -------
Is it normal condition or dhcpcd.exe should log it?
------- Comment #3 From 2004-06-03 21:14:26 -------
AFAIR after DHCP failure /etc/dhcpc/dhcpcd.exe is called with args:
"" "down" ""
Should be handled somehow, I guess.
------- Comment #4 From 2004-07-01 18:30:59 -------
Ok, added this check in dhcpcd-1.3.22pl4-alt2
------- Comment #5 From 2005-08-30 02:19:49 -------
closing
------- Comment #6 From 2005-08-30 02:28:54 -------
closing