Bug 4167 - Отсутсвует иконка ALTLinux в меню гнома
: Отсутсвует иконка ALTLinux в меню гнома
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/gnome-panel)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-05-15 02:30 by
Modified: 2009-05-10 09:32 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-05-15 02:30:41
Ошибка в патче gnome-panel-2.5.93-alt-menu_distribution.patch
Строка diff
+        "PANEL_STOCK_ALTLINUX", "gnome/distribution-menus/ALTLinux/."
приводит к отсутвию иконки дистрибутива.
Убрать скобки вокруг PANEL_STOCK_ALTLINUX.


Actual Results:  
Нет иконки altlinux

Expected Results:  
Иконка в глобальном меню.
------- Comment #1 From 2004-05-15 03:10:41 -------
Это фрагмент gnome-panel-2.5.93-alt-menu_distribution.patch с искомой строкой.
Какие скобки имеются ввиду? Причем иконка то показываеится :):)


diff -durN gnome-panel-2.5.93.orig/gnome-panel/distribution.c
gnome-panel-2.5.93/gnome-panel/distribution.c
--- gnome-panel-2.5.93.orig/gnome-panel/distribution.c  2002-11-27 12:33:37
+0300
+++ gnome-panel-2.5.93/gnome-panel/distribution.c       2004-03-18 20:14:18
+0300
@@ -38,6 +38,11 @@
         PANEL_STOCK_CDE, "cdemenu:/",
         NULL, NULL
        },
+       { DISTRIBUTION_ALTLINUX, "/etc/altlinux-release",
+         N_("AltLinux"), N_("AltLinux menus"),
+        PANEL_STOCK_ALTLINUX, "gnome/distribution-menus/ALTLinux/.",
+        NULL,NULL
+       },
        { DISTRIBUTION_UNKNOWN, NULL, NULL, NULL, NULL }
 };

------- Comment #2 From 2004-05-15 11:16:22 -------
not a bug.