Bug 4172 - kdelibs-3.2.2-alt7.1: unmet dependencies to libcrypto.so.4 libssl.so.4
: kdelibs-3.2.2-alt7.1: unmet dependencies to libcrypto.so.4 libssl.so.4
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/kdelibs)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-05-16 00:24 by
Modified: 2005-07-13 15:46 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-05-16 00:24:22
When updating kdelibs-3.2.2-alt7 to kdelibs-3.2.2-alt7.1

Steps to Reproduce:
# apt-get update
# apt-get install kdelibs

Actual Results:  
# apt-get install kdelibs         
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  kdelibs: Depends: libcrypto.so.4
           Depends: libssl.so.4
E: Broken packages
------- Comment #1 From 2004-05-16 00:27:09 -------
Unable to reproduce.
rpmquery apt?
------- Comment #2 From 2004-05-16 00:41:45 -------
# rpmquery apt
apt-0.5.15cnc6-alt2

#  rpm -q -R -p kdelibs-3.2.2-alt7.1.i586.rpm 
<SKIPPED>
libcrypto.so.4 
<SKIPPED>
libssl.so.4
<SKIPPED>

Но какой пакет предоставляет libssl.so.4?
В libssl лежит
/lib/libcrypto.so.0
/lib/libssl.so.0


------- Comment #3 From 2004-05-16 00:44:13 -------
Alexander Bokovoy <ab@altlinux.org> wrote to community@ at Sat, 15 May 2004
22:57:31:

OpenSSL сменил soname, соответственно, все от него
зависящее, требует пересборки. После пересборки все эти пакеты начинают
требовать новый OpenSSL, с новым soname, соответственно старый soname
пропадает и все пакеты, зависящие от OpenSSL должны быть обновлены.
------- Comment #4 From 2004-05-16 00:53:10 -------
Похоже, что у вас просто неполный репозитарий.

Должно быть так:

$ apt-cache showpkg libssl |grep -A1 ^Provides:
Provides: 
0.9.7d-alt1 - libssl.so.4 libcrypto.so.4
------- Comment #5 From 2004-05-16 02:05:41 -------
Да, действительно, kdelibs тут не причем.
Репозитарий полный, но где-то что-то не так с зависимостями на libssl.
Кажется я докопался до причины, сейчас напишу об этом в sisyphus@
------- Comment #6 From 2004-05-17 13:04:44 -------
kdelibs <= kdelibs-3.2.2-alt7.1 не будет работать с новым libssl без 
libssl-devel, т.к. /lib/libcrypto.so.0 и /lib/libssl.so.0 загружаются, как 
модули и *.so.4 ищет 
------- Comment #7 From 2004-05-17 13:19:27 -------
точнее не ищет *.so.4, что и было исправлено