Bug 4318 - requires on conflict packages reiserfsprogs and progsreiserfs
: requires on conflict packages reiserfsprogs and progsreiserfs
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/qtparted)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-06-08 15:07 by
Modified: 2007-07-19 16:55 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-06-08 15:07:16
не ставится из-за одновременной зависимости на progsreiserfs и reiserfsprogs 
(через reiserfs-utils)  , которые конфликтуют. 
если уже установлен - сносится dist-upgrade'ом. 

вводная: 
apt> show qtparted 
Package: qtparted 
Depends: e2fsprogs, libjpeg, libparted, libpng, libprogsreiserfs, libqt3,  
reiserfs-utils, progsreiserfs, libntfs, libe2fs, libICE.so.6, libSM.so.6,  
...skipped... 

apt> show progsreiserfs 
Package: progsreiserfs 
Provides: progsreiserfs (= 0.3.0.3-alt0.4) 
..skipped.. 

apt> show reiserfsprogs 
Package: reiserfsprogs 
Conflicts: progsreiserfs 
Provides: reiserfs-utils, reiserfsprogs (= 3.6.17-alt2) 
Obsoletes: reiserfs-utils 
..skipped.. 

теперь пытаемся ставить: 
apt> install qtparted 
The following packages have unmet dependencies: 
  qtparted: Depends: reiserfs-utils 
E: Broken packages 
.... что вполне понятно, т.к.  
apt> install reiserfs-utils 
Selecting reiserfsprogs for 'reiserfs-utils' 
, и пришлось бы поставить два конфликтующих пакета reiserfsprogs и  
progsreiserfs.
------- Comment #1 From 2004-06-14 16:06:11 -------
this fixed in 0.4.4-alt1