Bug 5138 - problem with h2ph
: problem with h2ph
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/perl4-compat)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-09-01 16:04 by
Modified: 2005-07-13 15:46 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-09-01 16:04:38
h2ph incorrect parse those lines (interpreted as inlined assembler) from
/usr/include/asm/unistd.h from 2.4.26/include/asm-x86_64/

extern inline long exit(int error_code)
{
     sys_exit(error_code);
}
------- Comment #1 From 2005-01-25 16:40:08 -------
Please try perl-5.8.6.  Hopefully this has been fixed. 
------- Comment #2 From 2005-02-04 00:28:30 -------
не-а, не пашет.
смотрим в
ftp.altlinux.ru/pub/people/mouse/Sisyphus/.../RPMS.base/glibc-kernheaders-2.4.26-alt1.x86_64.rpm
и пробуем его с h2ph. Только /usr/include/asm*, /usr/include/linux должны
указывать на эти glibc-kernheaders
------- Comment #3 From 2005-03-19 15:50:47 -------
I managed to reproduce the problem.
http://rt.perl.org/rt3/Ticket/Display.html?id=34493
------- Comment #4 From 2005-03-19 17:40:22 -------
It looks like I managed to fix the problem.
http://www.mail-archive.com/perl5-porters@perl.org/msg85524.html
------- Comment #5 From 2005-04-06 20:35:12 -------
Merged upstream as change #24054.
Please try perl4-compat-5.8.6-alt4.
------- Comment #6 From 2005-04-07 09:40:33 -------
thanks