Bug 5269 - [FR] add ksocrat dependency
: [FR] add ksocrat dependency
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/ksocrat-data)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-10-03 00:21 by
Modified: 2007-08-14 16:40 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-10-03 00:21:57
ksocrat (GPL) depends on ksocrat-data (non-free);
ksocrat works only with ksocrat-data;
ksocrat-data license allows to use it only with ksocrat.

Hence it seems reasonable for ksocrat-data to depend on ksocrat in its turn.

Pro: reduces user confusion
Contra: creates yet another cyclic dependency

for me, seems that "pro" is more important than "contra" here. :)
------- Comment #1 From 2007-08-14 16:40:20 -------
исправлено в 3.2.1-alt2