Bug 5398 - erroneous /usr/lib/menu/xcpufreq causes update-menus error
: erroneous /usr/lib/menu/xcpufreq causes update-menus error
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libhw-tools-x11)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-10-25 19:52 by
Modified: 2006-08-30 11:30 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-10-25 19:52:56
/usr/lib/menu/xcpufreq of libhw-tools-x11-0.1.9-alt1 suffers from a trivial typo
- it contains needs="" instead of needs="x11".
Steps to Reproduce:
1. # update-menus -N
2.
3.
Actual Results:  
/usr/lib/menu/xcpufreq: missing required tag: "needs"
Skipping file because of errors...

Resulting menus lack xcpufreq.

Expected Results:  
Generate menus with xcpufreq.
------- Comment #1 From 2005-02-09 17:05:27 -------
fixed (libhw-tools-x11-0.3.1)
------- Comment #2 From 2005-03-05 13:09:17 -------
uh, mmm... libhw-tools-x11 0.2.7.1-alt1 (BTW, where could I get libhw-tools-x11
0.3.1 from?) /usr/lib/menu/xcpufreq:

needs="libhw-tools-x11"

But there should be 'needs="x11"' exactly here...