Bug 5466 - mysqld выпадает с signal 11
: mysqld выпадает с signal 11
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/MySQL-server)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-11-08 12:49 by
Modified: 2005-06-02 08:43 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-11-08 12:49:23
если запустить команду mysqldump с ключем '--opt' ,  
то mysqld однозначно вываливается при попытке вычитать первую попавшуюся 
таблицу типа InnoDB . 

Actual Results:  
# cat /var/adm/mysql/info 
2004-Nov-08 11:39:53 :: startup 
041108 11:39:54  InnoDB: Database was not shut down normally. 
InnoDB: Starting recovery from log files... 
InnoDB: Starting log scan based on checkpoint at 
InnoDB: log sequence number 0 589138567 
InnoDB: Doing recovery: scanned up to log sequence number 0 589138567 
041108 11:39:54  InnoDB: Flushing modified pages from the buffer pool... 
041108 11:39:54  InnoDB: Started 
/usr/sbin/mysqld: ready for connections. 
Version: '4.0.21'  socket: '/mysql.sock'  port: 3306  ALT Linux MySQL RPM 
InnoDB: Error: select_lock_type is 99999999 inside ::start_stmt()! 
041108 11:40:37InnoDB: Assertion failure in thread 180235 in file ha_innodb.cc 
line 4581 
InnoDB: We intentionally generate a memory trap. 
InnoDB: Submit a detailed bug report to http://bugs.mysql.com. 
InnoDB: If you get repeated assertion failures or crashes, even 
InnoDB: immediately after the mysqld startup, there may be 
InnoDB: corruption in the InnoDB tablespace. See section 6.1 of 
InnoDB: http://www.innodb.com/ibman.php about forcing recovery. 
mysqld got signal 11; 
This could be because you hit a bug. It is also possible that this binary 
or one of the libraries it was linked against is corrupt, improperly built, 
or misconfigured. This error can also be caused by malfunctioning hardware. 
We will try our best to scrape up some info that will hopefully help diagnose 
the problem, but since we have already crashed, something is definitely wrong 
and this may fail. 
 
key_buffer_size=8388600 
read_buffer_size=131072 
max_used_connections=0 
max_connections=100 
threads_connected=1 
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 
225791 K 
bytes of memory 
Hope that's ok; if not, decrease some variables in the equation. 
 
thd=0x88afd08 
Attempting backtrace. You can use the following information to find out 
where mysqld died. If you see no messages after this, something went 
terribly wrong... 
frame pointer (ebp) is NULL, did you compile with 
-fomit-frame-pointer? Aborting backtrace! 
Trying to get some variables. 
Some pointers may be invalid and cause the dump to abort... 
thd->query at 0x88bb2a0 = show create table `results` 
thd->thread_id=2 
The manual page at http://www.mysql.com/doc/en/Crashing.html contains 
information that should help you find out what is causing the crash. 
2004-Nov-08 11:40:37 :: execution failed 
2004-Nov-08 11:40:37 :: shutdown
------- Comment #1 From 2005-06-02 08:43:51 -------
уже давно зафикилось.