Bug 554 - the start script for Emacs is not correct (not .po files match for po-mode)
: the start script for Emacs is not correct (not .po files match for po-mode)
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/gettext)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-02-06 17:13 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-02-06 17:13:11
The backslash in the filename specification in
/etc/emacs/site-start.d/gettext.el must be escaped (\"\\\\.po$\"),
otherwise the regex \".po$\" matches many other files.


---
Open a file called \"apo\" in Emacs.
---
The error is caused by the build procedure that uses 

cat <<EOF 

which substitutes escaped characters.

Better use a separate SOURCE as in RedHat\'s gettext. Their po-mode init-script
for Emacs is more powerful than the one present in ALT\'s pkg -- we should take
it.


By the way, I discovered that a newer version of gettext has been released
recently: <a
href="ftp://ftp.gnu.org/pub/gnu/gettext/gettext-0.11.tar.gz">ftp://ftp.gnu.org/pub/gnu/gettext/gettext-0.11.tar.gz</a>
------- Comment #1 From 2002-03-14 13:42:23 -------
Should be fixed in
gettext-0.11-alt1
------- Comment #2 From 2002-03-14 13:42:23 -------
Should be fixed in
gettext-0.11-alt1