Bug 5573 - rpmbuild -bE sometimes duplicates a head part of specfile
: rpmbuild -bE sometimes duplicates a head part of specfile
Status: CLOSED DUPLICATE of bug 5662
: Sisyphus
(All bugs in Sisyphus/rpm-build)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-11-28 05:01 by
Modified: 2005-07-13 15:47 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-11-28 05:01:22
This is a unique situation that's happen with only package, but under both ALM2.
2 and Sisyphus. When RpmBuild evaluates my specfile (rkhunter.spec), it displays 
heading block twice. This block contains ~11 lines. Remaining part of specfile 
is displayed normally. All other specfiles are processed normally.
Steps to Reproduce:
1. apt-get install wget rpm-build
2. wget http://ilya-evseev.narod.ru/posix/rkhunter/rkhunter.spec
3. rpmbuild -bE rkhunter.spec | egrep -i "^(Source|Patch).*:.*"

Actual Results:  
Source0:        http://downloads.rootkit.nl/rkhunter-1.1.8.tar.gz
Patch0:         os.dat.diff
Patch1:         development.diff
Source0:        http://downloads.rootkit.nl/rkhunter-1.1.8.tar.gz
Patch0:         os.dat.diff
Patch1:         development.diff

Expected Results:  
Source0:        http://downloads.rootkit.nl/rkhunter-1.1.8.tar.gz
Patch0:         os.dat.diff
Patch1:         development.diff
------- Comment #1 From 2004-12-02 23:19:26 -------
This happends due to BuildArch tag inserted after source/patch tags.

You should correct specfile according to alt packaging conventions,
including recommended tags order.
------- Comment #2 From 2004-12-09 17:55:54 -------
reopened to change resolved status
------- Comment #3 From 2004-12-09 17:56:27 -------

*** This bug has been marked as a duplicate of 5662 ***