Bug 5628 - build with gtkhtml3
: build with gtkhtml3
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/logjam)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-12-05 14:16 by
Modified: 2005-08-30 02:57 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-12-05 14:16:25
Вот патч для спека, с которым у меня собралась поддержка HTML предпросмотра:
-------------------
--- logjam.orig 2004-10-21 18:07:30 +0400
+++ logjam.spec 2004-12-05 14:05:05 +0300
@@ -1,6 +1,6 @@
 Name: logjam
 Version: 4.4.0
-Release: alt1.1.1
+Release: alt1.1.2

 Summary: LogJam is a client for LiveJournal.com
 Summary(ru_RU.KOI8-R): LogJam - ËÌÉÅÎÔ
ÄÌÑ LiveJournal.com
@@ -15,7 +15,7 @@
 Requires: libgtk+2, libcurl, libssl, libxml2, libgtkspell

 # Automatically added by buildreq on Mon Feb 09 2004
-BuildRequires: XFree86-devel XFree86-libs fontconfig freetype2 gcc-c++
glib-devel glib2-devel gnome-libs-devel gtk+-devel libart_lgpl-devel
libatk-devel libcurl-devel libgsf-devel libgtk+2-devel libgtkspell-devel
libpango-devel librsvg2-devel libssl-devel libstdc++-devel libxml2-devel
libxmms-devel perl-XML-Parser pkgconfig zlib-devel
+BuildRequires: XFree86-devel XFree86-libs fontconfig freetype2 gcc-c++
glib-devel glib2-devel gnome-libs-devel gtk+-devel libart_lgpl-devel
libatk-devel libcurl-devel libgsf-devel libgtk+2-devel libgtkspell-devel
libpango-devel librsvg2-devel libssl-devel libstdc++-devel libxml2-devel
libxmms-devel perl-XML-Parser pkgconfig zlib-devel libgnomeui-devel
libgnomeprintui-devel

 %description
 "LiveJournal.com... because you like to think other people care."
@@ -28,7 +28,8 @@

 %build
 %__subst 's,\.la,.so,' configure
-%configure --without-gtkhtml
+%__subst 's,libgtkhtml-3.0,libgtkhtml-3.1,' configure
+%configure 
 %make

 %install
-------------------
Видимо, нужно ещё добавить зависимости на библиотеки libgnomeui и
libgnomeprintui.
Работу без них не проверял, т.к. сносят много лишнего.
------- Comment #1 From 2005-01-27 11:21:27 -------
Recompiled with patch. Now SpellChecking and Preview as aviable