Bug 5900 - packaging bug: dependency on freetype version is missing
: packaging bug: dependency on freetype version is missing
: Sisyphus
(All bugs in Sisyphus/gimp)
: unstable
: all Linux
: P2 normal
Assigned To:
: 28382
  Show dependency tree
Reported: 2005-01-19 21:19 by
Modified: 2013-08-15 17:16 (History)



You need to log in before you can comment on or make changes to this bug.

Description From 2005-01-19 21:19:44

Here's the description from Gimp's message at startup:

FreeType version too old!

The GIMP requires FreeType version 2.1.7 or later.
Installed FreeType version is 2.1.4.

Somehow you or your software packager managed
to install The GIMP with an older FreeType version.

Please upgrade to FreeType version 2.1.7 or later.

And indeed, my configuration is as follows:

$ rpm -q gimp2   
$ rpm -qa '*freetype*'
$ rpm -q gimp2 --requires | fgrep freetype
$ rpm -q libfreetype.so.6 --whatprovides

Solved the issue by installing freetype2-2.1.9-alt2.
Steps to Reproduce:
1. Install gimp2-2.2.2-alt1 and freetype2-2.1.4-alt3
2. Start gimp

Actual Results:  
It shows an error message window and doesn't start.

Expected Results:  
Gimp starts.
------- Comment #1 From 2006-01-16 00:47:27 -------
Давно поправлено
------- Comment #2 From 2013-01-19 16:45:16 -------
The solution was probably not general enough:

we have again problems with gimp wanting precisely the version of a lib it
wants --  https://bugzilla.altlinux.org/show_bug.cgi?id=28382 .

If the formal dependencies of the RPM package were automatically derived from
the library version checking code of gimp, we would not have such problems
anymore after doing "apt-get install gimp" (updating only one package).
------- Comment #3 From 2013-08-15 17:16:58 -------
gimp-2.8.6-alt1 не возмущён.