Bug 6112 - beep segfaults on "toggle all windows" when playing
: beep segfaults on "toggle all windows" when playing
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/beep-statusdocklet)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-02-12 21:10 by
Modified: 2008-08-08 15:36 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-02-12 21:10:08
When beep is playing, middle-clicking the status docklet to toggle all windows
causes a SIGSEGV.
(When it is stopped, however, toggling all windows works as expected.)

$ rpm -qa '*beep*'
beep-input-mplayer-0.2.2-alt0.5.1
beep-0.9.7-alt1.1
beep-statusdocklet-0.2.2-alt0.5.1
beep-output-arts-0.2.2-alt0.5.1
beep-input-vorbis-0.9.7-alt1.1
libbeep-0.9.7-alt1.1
beep-extra-plugins-common-0.2.2-alt0.5.1
libbeep-devel-0.9.7-alt1.1
beep-output-crossfade-0.2.2-alt0.5.1

$ rpm -q xorg-x11-server libgtk+2
xorg-x11-server-6.8.2-alt3
libgtk+2-2.6.2-alt1

Steps to Reproduce:
1. Start playing any media file.
2. Middle-click the status docklet ("toggle all windows").
Actual Results:  
beep crashes with the following messages:
(beep-media-player:3833): Gdk-CRITICAL **: gdk_drawable_get_colormap: assertion
`GDK_IS_DRAWABLE (drawable)' failed

(beep-media-player:3833): Gdk-CRITICAL **: gdk_drawable_get_screen: assertion
`GDK_IS_DRAWABLE (drawable)' failed

(beep-media-player:3833): Gdk-CRITICAL **: gdk_drawable_get_depth: assertion
`GDK_IS_DRAWABLE (drawable)' failed

(beep-media-player:3833): Gdk-CRITICAL **: gdk_screen_get_rgb_colormap:
assertion `GDK_IS_SCREEN (screen)' failed

(beep-media-player:3833): Gdk-CRITICAL **: gdk_colormap_get_visual: assertion
`GDK_IS_COLORMAP (colormap)' failed

Received SIGSEGV

This could be a bug in BMP. If you don't know why this happened, send a mail to
us at beepmp-devel@lists.sourceforge.net

Aborted

================================
Backtrace:
(gdb) bt
#0  0x406d8e07 in gdk_screen_get_rgb_colormap ()
   from /usr/lib/libgdk-x11-2.0.so.0
#1  0x406d8e55 in gdk_draw_indexed_image () from /usr/lib/libgdk-x11-2.0.so.0
#2  0x08073a3d in vis_draw ()

Below that, the stack seems to be corrupt.
------- Comment #1 From 2006-04-02 23:13:43 -------
Больше не воспроизводится.
------- Comment #2 From 2008-08-08 15:36:36 -------
closed