Bug 6741 - new hotplug/libhw stopped to load modules for Aureal Vortex 2
: new hotplug/libhw stopped to load modules for Aureal Vortex 2
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/libhw)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-04-29 17:56 by
Modified: 2005-06-03 17:47 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-04-29 17:56:05
I found that my /etc/modules.conf contains settings conflicting w/ current
sound.rc loading logic. Since I can consider my modules.conf in its sound
section pretty standard, I guess, this new logic may be called somewhat ...
incomplete.

The conflicting lines are:

above snd-au8830 snd-pcm-oss
above snd-pcm-oss snd-mixer-oss

which cause automatic loading of OSS emulation layer. If these lines are
presented in modules.conf even plain modprobe snd-au8830 fails w/ the following
message:

[root@pyro alex]# modprobe snd-au8830
modprobe: Too deep recursion in module dependencies!
modprobe: Circular dependency?
Aborted
[root@pyro alex]# _

I guess new hotplug/libhw installation script should check for such strings in
modules.conf or or somehow force user to perform appropriate changes
------- Comment #1 From 2005-04-29 17:58:29 -------
Correction:

the problem string is 

above snd-pcm-oss snd-mixer-oss
------- Comment #2 From 2005-05-05 16:32:44 -------
Интересно, поймут ли меня пользователи, если я начну править modules.conf в
post
скриптах ?
------- Comment #3 From 2005-06-03 17:47:45 -------
не могу исправить, каждый должен исправить у себя сам.